aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/watchdog/watchdog_5.15.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-03 12:15:02 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-03 16:53:36 +0100
commite25b27c89dd13f5a311b49a974b4410e7993ddae (patch)
tree96676536bed986928ea1351169f2f11817b907d2 /meta/recipes-extended/watchdog/watchdog_5.15.bb
parent1310a71a81e0b19919fc622f676fa6106be6cf9d (diff)
downloadopenembedded-core-contrib-e25b27c89dd13f5a311b49a974b4410e7993ddae.tar.gz
watchdog: update to 5.15
Removed patches are all merged upstream. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/watchdog/watchdog_5.15.bb')
-rw-r--r--meta/recipes-extended/watchdog/watchdog_5.15.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/watchdog/watchdog_5.15.bb b/meta/recipes-extended/watchdog/watchdog_5.15.bb
new file mode 100644
index 0000000000..76a3b427c8
--- /dev/null
+++ b/meta/recipes-extended/watchdog/watchdog_5.15.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Software watchdog"
+DESCRIPTION = "Watchdog is a daemon that checks if your system is still \
+working. If programs in user space are not longer executed \
+it will reboot the system."
+HOMEPAGE = "http://watchdog.sourceforge.net/"
+BUGTRACKER = "http://sourceforge.net/tracker/?group_id=172030&atid=860194"
+
+LICENSE = "GPL-2.0+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ecc0551bf54ad97f6b541720f84d6569"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/watchdog/watchdog-${PV}.tar.gz \
+ file://watchdog-init.patch \
+ file://watchdog-conf.patch \
+"
+
+SRC_URI[md5sum] = "678c32f6f35a0492c9c1b76b4aa88828"
+SRC_URI[sha256sum] = "ffdc865137ad5d8e53664bd22bad4de6ca136d1b4636720320cb52af0c18947c"
+
+UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/watchdog/files/watchdog/"
+UPSTREAM_CHECK_REGEX = "/watchdog/(?P<pver>(\d+[\.\-_]*)+)/"
+
+inherit autotools
+inherit update-rc.d
+
+DEPENDS_append_libc-musl = " libtirpc "
+CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/tirpc "
+LDFLAGS_append_libc-musl = " -ltirpc "
+EXTRA_OECONF_append_libc-musl = " --disable-nfs "
+
+INITSCRIPT_NAME = "watchdog.sh"
+INITSCRIPT_PARAMS = "start 15 1 2 3 4 5 . stop 85 0 6 ."
+
+RRECOMMENDS_${PN} = "kernel-module-softdog"
+
+do_install_append() {
+ install -D ${S}/redhat/watchdog.init ${D}/${sysconfdir}/init.d/watchdog.sh
+}