aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/watchdog/watchdog-config.bb
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-26 16:55:02 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-09 11:52:09 +0100
commit6864ad2e863205472f8ea2057c61e949dc450151 (patch)
treea6a8edbec84402971536f65287ebdd778b2b30fc /meta/recipes-extended/watchdog/watchdog-config.bb
parentb76af8a0982c3c7473bd6ba067d1c8030d4d2f26 (diff)
downloadopenembedded-core-contrib-6864ad2e863205472f8ea2057c61e949dc450151.tar.gz
watchdog-config: Add recipe
Provides configuration files for watchdog. Add watchdog-config as a runtime dependence of watchdog and remove watchdog.conf file from watchdog installation. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/watchdog/watchdog-config.bb')
-rw-r--r--meta/recipes-extended/watchdog/watchdog-config.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-extended/watchdog/watchdog-config.bb b/meta/recipes-extended/watchdog/watchdog-config.bb
new file mode 100644
index 0000000000..8bf40f0f0e
--- /dev/null
+++ b/meta/recipes-extended/watchdog/watchdog-config.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Software watchdog"
+DESCRIPTION = "Watchdog is a daemon that checks if your system is still \
+working. If programs in user space are not longer executed it will reboot \
+the system."
+HOMEPAGE = "http://watchdog.sourceforge.net/"
+BUGTRACKER = "http://sourceforge.net/tracker/?group_id=172030&atid=860194"
+
+LICENSE = "MIT-X"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = " \
+ file://watchdog.default \
+ file://watchdog.conf \
+"
+
+do_install() {
+ install -Dm 0644 ${WORKDIR}/watchdog.default ${D}${sysconfdir}/default/watchdog
+ install -Dm 0644 ${WORKDIR}/watchdog.conf ${D}${sysconfdir}/watchdog.conf
+}
+