aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2014-05-30 21:03:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-06 09:16:42 +0100
commit5ffc10fcea78d1ad54dbcf854e16b0e2f19116fc (patch)
treed8a98efbec84603e5607a42ac992a260e6bccc8c /meta/recipes-extended/tzcode
parentf8125a1e9b6893a12355d55d4df584a8d97f0bff (diff)
downloadopenembedded-core-contrib-5ffc10fcea78d1ad54dbcf854e16b0e2f19116fc.tar.gz
Update tzcode to 2014d for zic fix
Changes affecting code zic no longer generates files containing time stamps well before the Big Bang. This works around GNOME bug 730332 <https://bugzilla.gnome.org/show_bug.cgi?id=730332>. (Thanks to Leonardo Chiquitto for reporting the bug, and to Arthur David Olson and James Cloos for suggesting improvements to the fix.) Changes affecting documentation tz-link.htm now mentions GNOME. Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/tzcode')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native.inc15
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2014c.bb25
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2014d.bb11
3 files changed, 26 insertions, 25 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native.inc b/meta/recipes-extended/tzcode/tzcode-native.inc
new file mode 100644
index 0000000000..f0343332ae
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+LICENSE = "PD & BSD"
+
+LIC_FILES_CHKSUM = "file://${WORKDIR}/README;md5=0b7570113550eb5d30aa4bd220964b8f"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 755 zic ${D}${bindir}/
+ install -m 755 zdump ${D}${bindir}/
+ install -m 755 tzselect ${D}${bindir}/
+}
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2014c.bb b/meta/recipes-extended/tzcode/tzcode-native_2014c.bb
deleted file mode 100644
index 65a31ae5ad..0000000000
--- a/meta/recipes-extended/tzcode/tzcode-native_2014c.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
-LICENSE = "PD & BSD"
-
-LIC_FILES_CHKSUM = "file://${WORKDIR}/README;md5=0b7570113550eb5d30aa4bd220964b8f"
-
-# note that we allow for us to use data later than our code version
-#
-SRC_URI =" ftp://ftp.iana.org/tz/releases/tzcode${PV}.tar.gz;name=tzcode \
- ftp://ftp.iana.org/tz/releases/tzdata2014c.tar.gz;name=tzdata"
-
-SRC_URI[tzcode.md5sum] = "657636f201ae8b561225afde49d274af"
-SRC_URI[tzcode.sha256sum] = "1461e6f6973797ccf516421b272a28082fe26754e8ae94967d8f931a4c8f011b"
-SRC_URI[tzdata.md5sum] = "fa7f3dc1c6f6238253a6f2b850467e2e"
-SRC_URI[tzdata.sha256sum] = "aa2924e012644de3a6cc3160ffff690cb3afecf350af435daefa43bb669fb8f1"
-
-S = "${WORKDIR}"
-
-inherit native
-
-do_install () {
- install -d ${D}${bindir}/
- install -m 755 zic ${D}${bindir}/
- install -m 755 zdump ${D}${bindir}/
- install -m 755 tzselect ${D}${bindir}/
-}
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2014d.bb b/meta/recipes-extended/tzcode/tzcode-native_2014d.bb
new file mode 100644
index 0000000000..8d20158c5b
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2014d.bb
@@ -0,0 +1,11 @@
+# note that we allow for us to use data later than our code version
+#
+SRC_URI =" ftp://ftp.iana.org/tz/releases/tzcode${PV}.tar.gz;name=tzcode \
+ ftp://ftp.iana.org/tz/releases/tzdata2014d.tar.gz;name=tzdata"
+
+SRC_URI[tzcode.md5sum] = "4a0f5f259ba8a2b826fffb1fa26d0134"
+SRC_URI[tzcode.sha256sum] = "e9c775bb76c9700521ada77776277c25f8650a22b56d46c9f00f4147970ef13e"
+SRC_URI[tzdata.md5sum] = "299b86c0368ecfb321f15d5c408a1d9b"
+SRC_URI[tzdata.sha256sum] = "4b4966912f5d4a299b0bdf47e6f3103d82dc6a0b5a6b321e2b9d5662597a62f0"
+
+require tzcode-native.inc