aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2017b.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2017-03-24 09:01:13 -0700
committerArmin Kuster <akuster808@gmail.com>2018-02-22 11:14:28 -0800
commit8f40f2e20c3b797304aa109823dcf271600cd832 (patch)
tree3db9b76fb77cbff19364f7a0e94212273fb0b5b9 /meta/recipes-extended/tzcode/tzcode-native_2017b.bb
parentca9fadbecba619b901f502969991f58934d8e319 (diff)
downloadopenembedded-core-contrib-8f40f2e20c3b797304aa109823dcf271600cd832.tar.gz
tzcode: update to 2017b
Briefly: Haiti has resumed DST. Changes to past and future time stamps Haiti resumed observance of DST in 2017. (Thanks to Steffen Thorsen.) Changes to past time stamps Liberia changed from -004430 to +00 on 1972-01-07, not 1972-05-01. Use "MMT" to abbreviate Liberia's time zone before 1972, as "-004430" is one byte over the POSIX limit. (Problem reported by Derick Rethans.) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 3b778b337bf2cb525f025978201a49a91088f005) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2017b.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2017b.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2017b.bb b/meta/recipes-extended/tzcode/tzcode-native_2017b.bb
new file mode 100644
index 0000000000..c76910a4df
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2017b.bb
@@ -0,0 +1,27 @@
+# note that we allow for us to use data later than our code version
+#
+SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+LICENSE = "PD & BSD & BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ef1a352b901ee7b75a75df8171d6aca7"
+
+SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
+ http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata"
+
+SRC_URI[tzcode.md5sum] = "afaf15deb13759e8b543d86350385b16"
+SRC_URI[tzcode.sha256sum] = "4d1735bb54e22b8d7443d4d1f1a13d007ae11be79a35e51f8e8322fb8e292d40"
+SRC_URI[tzdata.md5sum] = "50dc0dc50c68644c1f70804f2e7a1625"
+SRC_URI[tzdata.sha256sum] = "f8242a522ea3496b0ce4ff4f2e75a049178da21001a08b8e666d8cbe07d18086"
+
+S = "${WORKDIR}"
+
+inherit native
+
+EXTRA_OEMAKE += "cc=${CC}"
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 755 zic ${D}${bindir}/
+ install -m 755 zdump ${D}${bindir}/
+ install -m 755 tzselect ${D}${bindir}/
+}