aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2016e.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-06-14 14:50:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-23 14:23:27 +0100
commit5f3340e5c966f4233e0cd4ec468b20a1fd5a7346 (patch)
tree5510d301e2643a41f2c9b066737c636853e3f4c5 /meta/recipes-extended/tzcode/tzcode-native_2016e.bb
parent0474412a1d2b6b8a35931bb03fa58e31a48133e1 (diff)
downloadopenembedded-core-contrib-5f3340e5c966f4233e0cd4ec468b20a1fd5a7346.tar.gz
tzcode: update to 2016e
V2: typo in title (jet lagged) Changes to code zic now outputs a dummy transition at time 2**31 - 1 in zones whose POSIX-style TZ strings contain a '<'. This mostly works around Qt bug 53071 <https://bugreports.qt.io/browse/QTBUG-53071>. (Thanks to Zhanibek Adilbekov for reporting the Qt bug.) Changes affecting documentation and commentary tz-link.htm says why governments should give plenty of notice for time zone or DST changes, and refers to Matt Johnson's blog post. tz-link.htm mentions Tzdata for Elixir. (Thanks to Matt Johnson.) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2016e.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2016e.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2016e.bb b/meta/recipes-extended/tzcode/tzcode-native_2016e.bb
new file mode 100644
index 0000000000..78af639676
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2016e.bb
@@ -0,0 +1,27 @@
+# note that we allow for us to use data later than our code version
+#
+SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+LICENSE = "PD & BSD & BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=76ae2becfcb9a685041c6f166b44c2c2"
+
+SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
+ http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata"
+UPSTREAM_CHECK_URI = "http://www.iana.org/time-zones"
+
+SRC_URI[tzcode.md5sum] = "6e6d3f0046a9383aafba8c2e0708a3a3"
+SRC_URI[tzcode.sha256sum] = "57d8c4fcd5e8a90657d0e298eac5effb1a642119c92308db68d13a4612fa459e"
+
+SRC_URI[tzdata.md5sum] = "43f9f929a8baf0dd2f17efaea02c2d2a"
+SRC_URI[tzdata.sha256sum] = "ba00f899f18dc4048d7fa21f5e1fdef434496084eedc06f6caa15e5ecdb6bd81"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 755 zic ${D}${bindir}/
+ install -m 755 zdump ${D}${bindir}/
+ install -m 755 tzselect ${D}${bindir}/
+}