aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2015f.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2015-08-11 11:11:03 +0530
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-14 08:30:02 +0100
commitcbe4f950d775f17434ed4416b43b69a1c70feb2b (patch)
tree55f4a098b24cce4ceb87adaa6432b3fa0a53b602 /meta/recipes-extended/tzcode/tzcode-native_2015f.bb
parented5c6a0c80bac092e98f4d68dbc9cad77701bc7e (diff)
downloadopenembedded-core-contrib-cbe4f950d775f17434ed4416b43b69a1c70feb2b.tar.gz
tzcode-native: update to 2015f
Changes affecting code zdump and zic no longer warn about valid time zone abbreviations like '-05'. Some Visual Studio 2013 warnings have been suppressed. (Thanks to Kees Dekker.) 'date' no longer sets the time of day and its -a, -d, -n and -t options have been removed. Long obsolescent, the implementation of these features had porting problems. Builders no longer need to configure HAVE_ADJTIME, HAVE_SETTIMEOFDAY, or HAVE_UTMPX_H. (Thanks to Kees Dekker for pointing out the problem.) Changes affecting documentation The Theory file mentions naming issues earlier, as these seem to be poorly publicized (thanks to Gilmore Davidson for reporting the problem). tz-link.htm mentions Time Zone Database Parser (thanks to Howard Hinnant). Mention that Herbert Samuel introduced the term "Summer Time". Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2015f.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2015f.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2015f.bb b/meta/recipes-extended/tzcode/tzcode-native_2015f.bb
new file mode 100644
index 0000000000..a8865a3167
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2015f.bb
@@ -0,0 +1,25 @@
+# note that we allow for us to use data later than our code version
+#
+DESCRIPTION = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+LICENSE = "PD & BSD"
+
+LIC_FILES_CHKSUM = "file://${WORKDIR}/README;md5=d0ff93a73dd5bc3c6e724bb4343760f6"
+
+SRC_URI =" ftp://ftp.iana.org/tz/releases/tzcode${PV}.tar.gz;name=tzcode \
+ ftp://ftp.iana.org/tz/releases/tzdata2015f.tar.gz;name=tzdata"
+
+SRC_URI[tzcode.md5sum] = "19578d432ba8b92f73406a17a9bc268d"
+SRC_URI[tzcode.sha256sum] = "0c95e0a42bb61141f790f4f5f204b954d7654c894aa54a594a215d6f38de84ae"
+SRC_URI[tzdata.md5sum] = "e3b82732d20e973e48af1c6f13df9a1d"
+SRC_URI[tzdata.sha256sum] = "959f81b541e042ecb13c50097d264ae92ff03a57979c478dbcf24d5da242531d"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 755 zic ${D}${bindir}/
+ install -m 755 zdump ${D}${bindir}/
+ install -m 755 tzselect ${D}${bindir}/
+}