aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/texi2html
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-17 13:54:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-18 12:13:45 +0100
commit25e060dde108a3d534be78f84a481ae7aeaec915 (patch)
treef24bc5ad6d9e70ce7e7ac00f4d44682c93606bb8 /meta/recipes-extended/texi2html
parent1a731b5f3164bef1a3b7c4948e7bf3e384c31330 (diff)
downloadopenembedded-core-contrib-25e060dde108a3d534be78f84a481ae7aeaec915.tar.gz
texi2html: Add check for directory existence
Without this, if configure fails, it won't be able to run again as the directory already exists. (From OE-Core rev: 71a3ba536d022eea3a199cf4d6c5c791d91603a0) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/texi2html')
-rw-r--r--meta/recipes-extended/texi2html/texi2html_5.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-extended/texi2html/texi2html_5.0.bb b/meta/recipes-extended/texi2html/texi2html_5.0.bb
index 4b220f5ff8..f16841622e 100644
--- a/meta/recipes-extended/texi2html/texi2html_5.0.bb
+++ b/meta/recipes-extended/texi2html/texi2html_5.0.bb
@@ -16,7 +16,9 @@ inherit autotools gettext
do_configure_prepend() {
# Make a directory for the old gettext setup
- mkdir ${S}/po
+ if [ ! -d ${S}/po ]; then
+ mkdir ${S}/po
+ fi
}
do_configure_append() {