summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/stress-ng/stress-ng_0.10.00.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-07-30 18:47:42 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-31 23:02:56 +0100
commit3fcc10aeba208381166f09861d098d6459d44dfe (patch)
tree73dfb736f9e50152eed9be16879e33ac0742e3fc /meta/recipes-extended/stress-ng/stress-ng_0.10.00.bb
parenteede1c8e35e09afd06582312ca88a6413cdccf75 (diff)
downloadopenembedded-core-contrib-3fcc10aeba208381166f09861d098d6459d44dfe.tar.gz
stress-ng: add a recipe that replaces the original stress
The original stress is no longer maintained and the homepage went down. This commit replaces it with a maintained re-implementation by Ubuntu. Stress-ng preserves command line option compatibility (for the options that are used in rt-tests), so adjustment is simply changing the name of the executable. Rt-tests is the only user of stress(-ng) in oe-core. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/stress-ng/stress-ng_0.10.00.bb')
-rw-r--r--meta/recipes-extended/stress-ng/stress-ng_0.10.00.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.10.00.bb b/meta/recipes-extended/stress-ng/stress-ng_0.10.00.bb
new file mode 100644
index 0000000000..f7faf97e68
--- /dev/null
+++ b/meta/recipes-extended/stress-ng/stress-ng_0.10.00.bb
@@ -0,0 +1,20 @@
+SUMMARY = "System load testing utility"
+DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
+imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
+HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
+ file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
+ "
+SRC_URI[md5sum] = "46aa41d37690324ceab4febfcc549018"
+SRC_URI[sha256sum] = "d09dd2a1aea549e478995bf9be90b38906a4cdf33ea7b245ef9d46aa5213c074"
+
+DEPENDS = "coreutils-native"
+
+inherit bash-completion
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}