aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2012-11-27 10:04:35 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-03 13:52:05 +0000
commit9a9710169d01788725ace91dbea0b8a268cede7c (patch)
treeca16b0744aae6a84994d42af1868ddb21a8ff121 /meta/recipes-extended/slang
parent3067a914779694b51dcf934d8bc42daee30d36e8 (diff)
downloadopenembedded-core-contrib-9a9710169d01788725ace91dbea0b8a268cede7c.tar.gz
slang: explicity disable invoking onig module
We don't implement module onig in our recipes, so we should explicity disable its invoke in slang to avoid that slang's configure incorrectly tests the existence of onig. [YOCTO #2820] (From OE-Core rev: 38c1b92f188b7e9b27d7ce3f6a8ffbdd7e19f90d) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/slang')
-rw-r--r--meta/recipes-extended/slang/slang_2.2.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/slang/slang_2.2.4.bb b/meta/recipes-extended/slang/slang_2.2.4.bb
index b624af8c9c..60aac666c7 100644
--- a/meta/recipes-extended/slang/slang_2.2.4.bb
+++ b/meta/recipes-extended/slang/slang_2.2.4.bb
@@ -10,7 +10,7 @@ to recode S-Lang procedures in C if you need to."
HOMEPAGE = "http://www.jedsoft.org/slang/"
SECTION = "libs"
DEPENDS = "pcre"
-PR = "r11"
+PR = "r12"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02"
@@ -27,7 +27,7 @@ inherit autotools
SRC_URI[md5sum] = "7fcfd447e378f07dd0c0bae671fe6487"
SRC_URI[sha256sum] = "9a8257a9a2a55099af858b13338dc8f3a06dd2069f46f0df2c9c3bb84a01d5db"
-EXTRA_OECONF += " --without-z --without-png --x-includes=${STAGING_DIR_HOST}/usr/include/X11 --x-libraries=${STAGING_DIR_HOST}/usr/lib"
+EXTRA_OECONF += " --without-z --without-png --without-onig --x-includes=${STAGING_DIR_HOST}/usr/include/X11 --x-libraries=${STAGING_DIR_HOST}/usr/lib"
do_install() {
oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib'