aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2011-03-18 17:32:09 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-18 11:33:45 +0000
commit35c9ed7d49309ce0babbf93e205fb2dab117c69f (patch)
tree6fbfc46061519a8c0d8016dc619b9d62483bc24b /meta/recipes-extended/slang
parent7a0922ba2e7a33005a8830ff8a4e6b1408b29aa5 (diff)
downloadopenembedded-core-contrib-35c9ed7d49309ce0babbf93e205fb2dab117c69f.tar.gz
slang: specify --x-includes to pass qa sanity check
slang by default hardcodes a list of host dirs to search for X header files, which may break qa sanity check. Use --x-includes to specify sysroot as the fix. Fix [YOCTO 907] Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/recipes-extended/slang')
-rw-r--r--meta/recipes-extended/slang/slang_2.2.2.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-extended/slang/slang_2.2.2.bb b/meta/recipes-extended/slang/slang_2.2.2.bb
index f77a946c6e..29d9e46d51 100644
--- a/meta/recipes-extended/slang/slang_2.2.2.bb
+++ b/meta/recipes-extended/slang/slang_2.2.2.bb
@@ -10,7 +10,7 @@ to recode S-Lang procedures in C if you need to."
SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "pcre"
-PR = "r1"
+PR = "r2"
LICENSE = "GPL Artistic"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
@@ -24,6 +24,7 @@ inherit autotools
SRC_URI[md5sum] = "974437602a781cfe92ab61433dd16d03"
SRC_URI[sha256sum] = "cfaf8551fa3855f9b0043309bb553ef6d457f931b404df5a6ba6a5a69371fc42"
+EXTRA_OECONF += " --x-includes=${STAGING_DIR_HOST}/usr/X11/include"
do_install() {
oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib'
}