aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/shadow
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-05-22 12:38:09 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-30 10:43:41 +0100
commit87d43530b434e5be139b845d6b96bbf2d885867d (patch)
tree204b9c3a8165a53a58cf12e5f540f09bb0f3b2d9 /meta/recipes-extended/shadow
parent0a621679772d7996c6342ad1e99de484082d9987 (diff)
downloadopenembedded-core-contrib-87d43530b434e5be139b845d6b96bbf2d885867d.tar.gz
shadow: use BPN for alternatives
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-extended/shadow')
-rw-r--r--meta/recipes-extended/shadow/shadow_4.1.4.3.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/shadow/shadow_4.1.4.3.bb b/meta/recipes-extended/shadow/shadow_4.1.4.3.bb
index 098b0b0584..506f4e6da5 100644
--- a/meta/recipes-extended/shadow/shadow_4.1.4.3.bb
+++ b/meta/recipes-extended/shadow/shadow_4.1.4.3.bb
@@ -89,13 +89,13 @@ do_install_append() {
# Move binaries to the locations we want
rm ${D}${sbindir}/vigr
- ln -sf vipw.${PN} ${D}${base_sbindir}/vigr
+ ln -sf vipw.${BPN} ${D}${base_sbindir}/vigr
mv ${D}${sbindir}/vipw ${D}${base_sbindir}/vipw
mv ${D}${bindir}/login ${D}${base_bindir}/login
# Handle link properly after rename, otherwise missing files would
# lead rpm failed dependencies.
- ln -sf newgrp.${PN} ${D}${bindir}/sg
+ ln -sf newgrp.${BPN} ${D}${bindir}/sg
}
inherit update-alternatives