aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/shadow
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-07-23 14:37:16 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-26 14:39:47 +0100
commite06414092c7aa4fce1173f00e610a33a0deca9cd (patch)
tree4e2ad3b954e0aa7779e5ddfca74dca0a872d65c7 /meta/recipes-extended/shadow
parent2d114fd0cdf7486f18e53f2bf41c4f559e4b4a8d (diff)
downloadopenembedded-core-contrib-e06414092c7aa4fce1173f00e610a33a0deca9cd.tar.gz
shadow-native: use 'users' group by default
The rootfs has 'users' group at number 100 and without this fix it would assign to a non-existent group and if a group with gid as 1000 is created later it would own all files for users created. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/shadow')
-rw-r--r--meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb b/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
index 1e071f1bed..cd5605f81c 100644
--- a/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
+++ b/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
@@ -7,7 +7,7 @@ LICENSE = "BSD | Artistic-1.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=08c553a87d4e51bbed50b20e0adcaede \
file://src/passwd.c;firstline=8;endline=30;md5=2899a045e90511d0e043b85a7db7e2fe"
-PR = "r6"
+PR = "r7"
SRC_URI = "http://pkg-shadow.alioth.debian.org/releases/${BPN}-${PV}.tar.bz2 \
file://shadow.automake-1.11.patch \
@@ -46,4 +46,7 @@ do_install_append() {
# Now we don't have a mail system. Disable mail creation for now.
sed -i 's:/bin/bash:/bin/sh:g' ${D}${sysconfdir}/default/useradd
sed -i '/^CREATE_MAIL_SPOOL/ s:^:#:' ${D}${sysconfdir}/default/useradd
+
+ # Use users group by default
+ sed -i 's,^GROUP=1000,GROUP=100,g' ${D}${sysconfdir}/default/useradd
}