summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2019-11-22 16:24:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-25 22:03:43 +0000
commitad08385393bb0d072f2f27f5a189041037e06195 (patch)
tree0c9bf737ae3713d65fbd1f04dea4e95e76c9bf95 /meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
parent406e675a2269d731786264cf8cf5dab3825b04ab (diff)
downloadopenembedded-core-contrib-ad08385393bb0d072f2f27f5a189041037e06195.tar.gz
rpcbind: use upstream systemd service
Use upstream systemd service files instead of our own service files. This also makes sure that /run/rpcbind.sock is used which fixes the following systemd warning: /usr/lib/systemd/system/rpcbind.socket:5: ListenStream= references a path below legacy directory /var/run/, updating /var/run/rpcbind.sock \xe2\x86\x92 /run/rpcbind.sock; please update the unit file accordingly. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb')
-rw-r--r--meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb13
1 files changed, 2 insertions, 11 deletions
diff --git a/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb b/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
index 19d778b6d1..aff00e56e6 100644
--- a/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
+++ b/meta/recipes-extended/rpcbind/rpcbind_1.2.5.bb
@@ -13,9 +13,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b46486e4c4a416602693a711bb5bfa39 \
SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \
file://init.d \
file://rpcbind.conf \
- file://rpcbind.socket \
- file://rpcbind.service \
file://rpcbind_add_option_to_fix_port_number.patch \
+ file://0001-systemd-use-EnvironmentFile.patch \
"
SRC_URI[md5sum] = "ed46f09b9c0fa2d49015f6431bc5ea7b"
SRC_URI[sha256sum] = "2ce360683963b35c19c43f0ee2c7f18aa5b81ef41c3fdbd15ffcb00b8bffda7a"
@@ -28,7 +27,7 @@ PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
INITSCRIPT_NAME = "rpcbind"
INITSCRIPT_PARAMS = "start 12 2 3 4 5 . stop 60 0 1 6 ."
-SYSTEMD_SERVICE_${PN} = "rpcbind.service"
+SYSTEMD_SERVICE_${PN} = "rpcbind.service rpcbind.socket"
inherit useradd
@@ -50,12 +49,4 @@ do_install_append () {
-e 's,/sbin/,${sbindir}/,g' \
${WORKDIR}/init.d > ${D}${sysconfdir}/init.d/rpcbind
chmod 0755 ${D}${sysconfdir}/init.d/rpcbind
-
- install -m 0755 ${WORKDIR}/rpcbind.conf ${D}${sysconfdir}
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/rpcbind.socket ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/rpcbind.service ${D}${systemd_unitdir}/system
- sed -i -e 's,@SBINDIR@,${sbindir},g' \
- -e 's,@SYSCONFDIR@,${sysconfdir},g' \
- ${D}${systemd_unitdir}/system/rpcbind.service
}