aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/quota/quota_4.03.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2016-07-19 15:39:20 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-25 23:46:57 +0100
commitaff36f4c4d241707744fe13b6310fb894610a0f3 (patch)
treeae1b847d0da1f597fe1147c4bcee5fe95ddd3d36 /meta/recipes-extended/quota/quota_4.03.bb
parentfba47b9d881af40eb2462aefd19040dc08314365 (diff)
downloadopenembedded-core-contrib-aff36f4c4d241707744fe13b6310fb894610a0f3.tar.gz
quota: make compile pass when disable rpc
When 'rpc' is not in PACKAGECONFIG, option '--disable-rpc' is passed to configure and then compile fails. Backport patches to make quota build successfully. Update fcntl.patch that part of the patches are added by 0002-Allow-building-on-systems-that-do-not-have-rpc-heade.patch. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/quota/quota_4.03.bb')
-rw-r--r--meta/recipes-extended/quota/quota_4.03.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-extended/quota/quota_4.03.bb b/meta/recipes-extended/quota/quota_4.03.bb
index 4a980464b1..22aab4147b 100644
--- a/meta/recipes-extended/quota/quota_4.03.bb
+++ b/meta/recipes-extended/quota/quota_4.03.bb
@@ -12,6 +12,10 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/project/linuxquota/quota-tools/${PV}/quota-${PV
file://0001-Do-not-accidentaly-override-commandline-passed-CFLAG.patch \
file://fcntl.patch \
file://remove_non_posix_types.patch \
+ file://0001-Use-NGROUPS_MAX-instead-of-NGROUPS.patch \
+ file://0002-Allow-building-on-systems-that-do-not-have-rpc-heade.patch \
+ file://0003-Don-t-build-rpc.rquotad-when-disable-rpc-was-request.patch \
+ file://0004-Fix-warnings-due-to-missing-stdlib.h.patch \
"
SRC_URI_append_libc-musl = " file://replace_getrpcbynumber_r.patch"
@@ -25,8 +29,8 @@ DEPENDS = "gettext-native e2fsprogs libnl dbus"
inherit autotools-brokensep gettext pkgconfig
-CFLAGS += "-I${STAGING_INCDIR}/tirpc"
-LDFLAGS += "-ltirpc"
+CFLAGS += "${@bb.utils.contains('PACKAGECONFIG', 'rpc', '-I${STAGING_INCDIR}/tirpc', '', d)}"
+LDFLAGS += "${@bb.utils.contains('PACKAGECONFIG', 'rpc', '-ltirpc', '', d)}"
ASNEEDED = ""
PACKAGECONFIG ??= "tcp-wrappers rpc bsd"