aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/psmisc/psmisc.inc
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-11-02 16:43:44 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-18 18:00:21 +0000
commitdfda42b624b539125443f30ae3a587ae55691ba4 (patch)
tree24e901a79ff365e77320588a8a15b7aed1cad79b /meta/recipes-extended/psmisc/psmisc.inc
parent3acae2dcd130122fe76504ec855af78db829d6ec (diff)
downloadopenembedded-core-contrib-dfda42b624b539125443f30ae3a587ae55691ba4.tar.gz
psmisc: update to 23.0
Switch to gitlab, as that's where development now happens. Drop two upstreamed patches, add apatches to avoid newly introduced build errors, and a gettext fix suggested here: http://lists.openembedded.org/pipermail/openembedded-core/2017-November/144566.html Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/psmisc/psmisc.inc')
-rw-r--r--meta/recipes-extended/psmisc/psmisc.inc9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-extended/psmisc/psmisc.inc b/meta/recipes-extended/psmisc/psmisc.inc
index 66a784b53c..527a1d590f 100644
--- a/meta/recipes-extended/psmisc/psmisc.inc
+++ b/meta/recipes-extended/psmisc/psmisc.inc
@@ -16,6 +16,15 @@ S = "${WORKDIR}/psmisc-${PV}"
inherit autotools gettext
+# Upstream has a custom autogen.sh which invokes po/update-potfiles as they
+# don't ship a po/POTFILES.in (which is silly). Without that file gettext
+#doesn't believe po/ is a gettext directory and won't generate po/Makefile.
+EXTRA_AUTORECONF=""
+do_configure_prepend() {
+ ( cd ${S} && po/update-potfiles )
+}
+
+
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"