aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/perl/libxml-sax-perl_1.00.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-03-28 19:49:52 -0700
committerTim Orling <timothy.t.orling@linux.intel.com>2018-03-29 00:05:47 -0700
commitee435f02d4704c89f81b9ad65019d087883736de (patch)
tree5c7b9e1e9df14a9a0b1d147859e3d95f85530580 /meta/recipes-extended/perl/libxml-sax-perl_1.00.bb
parentaf7ca3e3596784c5837e9bd339cc7114883ce67a (diff)
downloadopenembedded-core-contrib-timo/libxml-sax-perl-1.00.tar.gz
libxml-sax-perl: upgrade 0.99 -> 1.00timo/libxml-sax-perl-1.00
Upstream release notes: 1.00 15 Feb 2018 Grant McLean - Add makefile dependency to fix order of build steps RT#62289 (patch from Ed J) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/perl/libxml-sax-perl_1.00.bb')
-rw-r--r--meta/recipes-extended/perl/libxml-sax-perl_1.00.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-extended/perl/libxml-sax-perl_1.00.bb b/meta/recipes-extended/perl/libxml-sax-perl_1.00.bb
new file mode 100644
index 0000000000..141830efe8
--- /dev/null
+++ b/meta/recipes-extended/perl/libxml-sax-perl_1.00.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Perl module for using and building Perl SAX2 XML processors"
+HOMEPAGE = "http://search.cpan.org/dist/XML-SAX/"
+DESCRIPTION = "XML::SAX consists of several framework classes for using and \
+building Perl SAX2 XML parsers, filters, and drivers. It is designed \
+around the need to be able to "plug in" different SAX parsers to an \
+application without requiring programmer intervention. Those of you \
+familiar with the DBI will be right at home. Some of the designs \
+come from the Java JAXP specification (SAX part), only without the \
+javaness."
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+DEPENDS += "libxml-namespacesupport-perl-native"
+RDEPENDS_${PN} += "libxml-namespacesupport-perl libxml-sax-base-perl perl-module-file-temp"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-SAX-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "861a454f7bf269990ed2c1c125f4db48"
+SRC_URI[sha256sum] = "45ea6564ef8692155d57b2de0862b6442d3c7e29f4a9bc9ede5d7ecdc74c2ae3"
+
+S = "${WORKDIR}/XML-SAX-${PV}"
+
+inherit cpan ptest-perl
+
+do_install_ptest() {
+ cp -r ${B}/testfiles ${D}${PTEST_PATH}
+ chown -R root:root ${D}${PTEST_PATH}/testfiles
+}
+
+BBCLASSEXTEND = "native"