aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
diff options
context:
space:
mode:
authorXin Ouyang <Xin.Ouyang@windriver.com>2012-11-30 18:29:59 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-03 15:22:34 +0000
commit3230d943699c77f3fe9ce9d9949eae21d825186d (patch)
tree7ddb287f682ab3c0ad27bd4829a47c2745e33e9e /meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
parent821401df8cd79e4878ad87f918b1ce8d0da141ec (diff)
downloadopenembedded-core-contrib-3230d943699c77f3fe9ce9d9949eae21d825186d.tar.gz
libxml-sax-base-perl: add recipe for libxml-sax-perl
If libxml-sax-base-perl is not installed on the target, libxml-sax-perl would be fail to use. So add the recipe. # cat > test.pl <<-EOF #!/usr/bin/perl use XML::SAX; EOF # perl ./test.pl Can't locate XML/SAX/Exception.pm in @INC ... Also inherit allarch for three perl modules. Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/perl/libxml-sax-perl_0.99.bb')
-rw-r--r--meta/recipes-extended/perl/libxml-sax-perl_0.99.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb b/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
index 3a0873fe41..647cb77fa8 100644
--- a/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
+++ b/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
@@ -10,8 +10,8 @@ javaness."
SECTION = "libs"
LICENSE = "Artistic-1.0 | GPL-1.0+"
DEPENDS += "libxml-namespacesupport-perl-native"
-RDEPENDS_${PN} += "libxml-namespacesupport-perl perl-module-file-temp"
-PR = "r1"
+RDEPENDS_${PN} += "libxml-namespacesupport-perl libxml-sax-base-perl perl-module-file-temp"
+PR = "r2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3"
@@ -22,6 +22,6 @@ SRC_URI[sha256sum] = "32b04b8e36b6cc4cfc486de2d859d87af5386dd930f2383c49347050d6
S = "${WORKDIR}/XML-SAX-${PV}"
-inherit cpan
+inherit cpan allarch
BBCLASSEXTEND = "native"