aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pam
diff options
context:
space:
mode:
authorJian Liu <jian.liu@windriver.com>2014-11-21 17:17:13 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-03 12:24:00 +0000
commit1a46946b82acade0942dfd4e1fc4fc6f799346b3 (patch)
tree74ce2cae8691c7bbc9ccc103a12575ae4ce5a160 /meta/recipes-extended/pam
parentb4f4d0f804d126c9d4aa002a1ca4c83b249f1e8c (diff)
downloadopenembedded-core-contrib-1a46946b82acade0942dfd4e1fc4fc6f799346b3.tar.gz
libpam: avoid overwritting editable files during package updating
Use CONFFILES to mark editable files as such, /etc/pam.d/common-session /etc/pam.d/common-auth /etc/pam.d/common-password /etc/pam.d/common-session-noninteractive /etc/pam.d/common-account If there is no %config micro before the file name in the spec file, this file will be overwritten after updating package. This will make our settings lost. (From OE-Core rev: 078fedcc0b7d50e7001c587968319f1b45b3c1ba) Signed-off-by: Jian Liu <jian.liu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/pam')
-rw-r--r--meta/recipes-extended/pam/libpam_1.1.6.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.1.6.bb b/meta/recipes-extended/pam/libpam_1.1.6.bb
index 3b6d5144f9..b3b39da864 100644
--- a/meta/recipes-extended/pam/libpam_1.1.6.bb
+++ b/meta/recipes-extended/pam/libpam_1.1.6.bb
@@ -163,3 +163,9 @@ python do_pam_sanity () {
addtask pam_sanity before do_configure
BBCLASSEXTEND = "nativesdk native"
+
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-session"
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-auth"
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-password"
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-session-noninteractive"
+CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-account"