aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pam
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-07-04 13:12:38 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-17 10:42:45 +0100
commite59a0bac95ce025a6b826be28ccc9e42ca4b5a29 (patch)
tree80d81eeccc0d2ec313e2c00477869500ad55e051 /meta/recipes-extended/pam
parent5a59bf0778608b7c5e1073bf38d36b98d831db0d (diff)
downloadopenembedded-core-contrib-e59a0bac95ce025a6b826be28ccc9e42ca4b5a29.tar.gz
libpam: Fix build with eglibc 2.16
pam_unix_acct.c: In function '_unix_run_verify_binary': pam_unix_acct.c:97:19: error: storage size of 'rlim' isn't known pam_unix_acct.c:106:19: error: 'RLIMIT_NOFILE' undeclared (first use in this function) pam_unix_acct.c:106:19: note: each undeclared identifier is reported only once for each function it appears in Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/pam')
-rw-r--r--meta/recipes-extended/pam/libpam/include-sys-resource.patch12
-rw-r--r--meta/recipes-extended/pam/libpam_1.1.5.bb6
2 files changed, 16 insertions, 2 deletions
diff --git a/meta/recipes-extended/pam/libpam/include-sys-resource.patch b/meta/recipes-extended/pam/libpam/include-sys-resource.patch
new file mode 100644
index 0000000000..0108a889a9
--- /dev/null
+++ b/meta/recipes-extended/pam/libpam/include-sys-resource.patch
@@ -0,0 +1,12 @@
+Index: Linux-PAM-1.1.5/modules/pam_unix/pam_unix_acct.c
+===================================================================
+--- Linux-PAM-1.1.5.orig/modules/pam_unix/pam_unix_acct.c 2012-07-04 12:37:44.881136025 -0700
++++ Linux-PAM-1.1.5/modules/pam_unix/pam_unix_acct.c 2012-07-04 12:38:00.601136785 -0700
+@@ -47,6 +47,7 @@
+ #include <time.h> /* for time() */
+ #include <errno.h>
+ #include <sys/wait.h>
++#include <sys/resource.h>
+
+ #include <security/_pam_macros.h>
+
diff --git a/meta/recipes-extended/pam/libpam_1.1.5.bb b/meta/recipes-extended/pam/libpam_1.1.5.bb
index 08ce1d13b3..275e5d8424 100644
--- a/meta/recipes-extended/pam/libpam_1.1.5.bb
+++ b/meta/recipes-extended/pam/libpam_1.1.5.bb
@@ -9,12 +9,14 @@ SECTION = "base"
LICENSE = "GPLv2+ | BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=ca0395de9a86191a078b8b79302e3083"
-PR = "r3"
+PR = "r4"
SRC_URI = "https://fedorahosted.org/releases/l/i/linux-pam/Linux-PAM-${PV}.tar.bz2 \
file://99_pam \
file://pam.d/* \
- file://libpam-xtests.patch"
+ file://libpam-xtests.patch \
+ file://include-sys-resource.patch \
+ "
SRC_URI_append_libc-uclibc = " file://pam-no-innetgr.patch"
a id='n265' href='#n265'>265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423