aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pam/libpam
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2011-07-19 17:08:31 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-27 11:54:50 +0100
commitf9158bf219479c2da56dd21a13ecee3176cd6f8a (patch)
tree17a366783675f56bd7e6df8a65c539c88e2d19ae /meta/recipes-extended/pam/libpam
parent4f4e1ee82cff6a9e3103366169ef9f21964db3ba (diff)
downloadopenembedded-core-contrib-f9158bf219479c2da56dd21a13ecee3176cd6f8a.tar.gz
libpam: update to 1.1.4 and add subpackage xtests
Update libpam to 1.1.4, and add dependecy cracklib because run xtexts will need pam-plugin-cracklib. There are some additional checks under subdirectory xtests and make it as a subpackage libpam-xtests. Signed-off-by: Kang Kai <kai.kang@windriver.com>
Diffstat (limited to 'meta/recipes-extended/pam/libpam')
-rw-r--r--meta/recipes-extended/pam/libpam/libpam-xtests.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-extended/pam/libpam/libpam-xtests.patch b/meta/recipes-extended/pam/libpam/libpam-xtests.patch
new file mode 100644
index 0000000000..be687457f8
--- /dev/null
+++ b/meta/recipes-extended/pam/libpam/libpam-xtests.patch
@@ -0,0 +1,35 @@
+This patch is used to create a new sub package libpam-xtests to do more checks.
+
+Upstream-Status: Pending
+
+Signed-off-by: Kang Kai <kai.kang@windriver.com>
+--- Linux-PAM-1.1.4/xtests/Makefile.am.orig 2011-07-19 17:00:09.619980001 +0800
++++ Linux-PAM-1.1.4/xtests/Makefile.am 2011-07-19 16:54:00.229979998 +0800
+@@ -7,7 +7,7 @@
+ AM_LDFLAGS = -L$(top_builddir)/libpam -lpam \
+ -L$(top_builddir)/libpam_misc -lpam_misc
+
+-CLEANFILES = *~ $(XTESTS)
++CLEANFILES = *~
+
+ EXTRA_DIST = run-xtests.sh tst-pam_dispatch1.pamd tst-pam_dispatch2.pamd \
+ tst-pam_dispatch3.pamd tst-pam_dispatch4.pamd \
+@@ -51,3 +51,18 @@
+
+ xtests: $(XTESTS) run-xtests.sh
+ "$(srcdir)"/run-xtests.sh "$(srcdir)" ${XTESTS} ${NOSRCTESTS}
++
++all: $(XTESTS)
++
++install: install_xtests
++
++install_xtests:
++ $(INSTALL) -d $(DESTDIR)$(pkgdatadir)/xtests
++ for file in $(EXTRA_DIST) ; do \
++ $(INSTALL) $$file $(DESTDIR)$(pkgdatadir)/xtests ; \
++ done
++ for file in $(XTESTS); do \
++ $(INSTALL) .libs/$$file $(DESTDIR)$(pkgdatadir)/xtests ; \
++ done
++
++.PHONY: all install_xtests