aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pam/libpam
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-06-03 09:42:01 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-08 17:30:51 +0100
commit6ec229d8dec6a5978ebf6b264c332590c8be0b3a (patch)
treed505d45d78a90d751f7a9403a608d504d666906c /meta/recipes-extended/pam/libpam
parent72433314bcc0e8952ca280c01f42f2c40b825b50 (diff)
downloadopenembedded-core-contrib-6ec229d8dec6a5978ebf6b264c332590c8be0b3a.tar.gz
libpam: Fix wrong crypt library detection
Surfaced when building with musl This details are in patch headers Enabel innetgr.patch for musl as well Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/pam/libpam')
-rw-r--r--meta/recipes-extended/pam/libpam/crypt_configure.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/pam/libpam/crypt_configure.patch b/meta/recipes-extended/pam/libpam/crypt_configure.patch
new file mode 100644
index 0000000000..efa82fb9b9
--- /dev/null
+++ b/meta/recipes-extended/pam/libpam/crypt_configure.patch
@@ -0,0 +1,31 @@
+This patch fixes a case where it find crypt defined in libc (musl) but
+not in specified libraries then it ends up assigning
+
+LIBCRYPT="-l" which then goes into makefile cause all sort of problems
+e.g.
+
+ld: cannot find -l-m32
+| collect2: error: ld returned 1 exit status
+
+The reason is that -l appears on commandline with out any library and
+compiler treats the next argument as library name whatever it is.
+
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: Linux-PAM-1.1.6/configure.in
+===================================================================
+--- Linux-PAM-1.1.6.org/configure.in
++++ Linux-PAM-1.1.6/configure.in
+@@ -400,7 +400,9 @@ AS_IF([test "x$ac_cv_header_xcrypt_h" =
+ [crypt_libs="crypt"])
+
+ BACKUP_LIBS=$LIBS
+-AC_SEARCH_LIBS([crypt],[$crypt_libs], LIBCRYPT="-l$ac_lib", LIBCRYPT="")
++AC_SEARCH_LIBS([crypt],[$crypt_libs],
++ [test "$ac_cv_search_crypt" = "none required" ||
++ LIBCRYPT="$ac_cv_search_crypt"])
+ AC_CHECK_FUNCS(crypt_r crypt_gensalt_r)
+ LIBS=$BACKUP_LIBS
+ AC_SUBST(LIBCRYPT)