aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/packagegroups
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 02:04:28 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:53 -0700
commit61b134fd082b4ca2866b98655c5fc3a275834464 (patch)
tree182f558d36f3e69018560401dc563b448ac9807f /meta/recipes-extended/packagegroups
parente7abf8437c7128e8541411213d262137520456a7 (diff)
downloadopenembedded-core-contrib-61b134fd082b4ca2866b98655c5fc3a275834464.tar.gz
packagegroup-core-lsb: rework
Create package groups covering the Core, Desktop, Runtime Languages sections of the LSB specification 4.1. Most of the packages were just moved around or copied in from packagegroup-core-basic (which is currently included in LSB images anyway) with the eventual aim of having the LSB package groups be completely independent as well as following the specification as closely as possible. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/packagegroups')
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb110
1 files changed, 77 insertions, 33 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
index b8031e5a19..707ccc1201 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
@@ -13,43 +13,39 @@ PACKAGES = "\
packagegroup-core-lsb \
packagegroup-core-sys-extended \
packagegroup-core-db \
- packagegroup-core-misc \
packagegroup-core-perl \
packagegroup-core-python \
packagegroup-core-tcl \
- packagegroup-core-lsb-perl-add \
- packagegroup-core-lsb-python-add \
- packagegroup-core-lsb-graphic-add \
+ packagegroup-core-lsb-misc \
+ packagegroup-core-lsb-core \
+ packagegroup-core-lsb-perl \
+ packagegroup-core-lsb-python \
+ packagegroup-core-lsb-desktop \
packagegroup-core-lsb-runtime-add \
- packagegroup-core-lsb-command-add \
"
RDEPENDS_packagegroup-core-lsb = "\
packagegroup-core-sys-extended \
packagegroup-core-db \
- packagegroup-core-misc \
packagegroup-core-perl \
packagegroup-core-python \
packagegroup-core-tcl \
- packagegroup-core-lsb-perl-add \
- packagegroup-core-lsb-python-add \
- packagegroup-core-lsb-graphic-add \
+ packagegroup-core-lsb-misc \
+ packagegroup-core-lsb-core \
+ packagegroup-core-lsb-perl \
+ packagegroup-core-lsb-python \
+ packagegroup-core-lsb-desktop \
packagegroup-core-lsb-runtime-add \
- packagegroup-core-lsb-command-add \
"
+
RDEPENDS_packagegroup-core-sys-extended = "\
- binutils \
- binutils-symlinks \
- chkconfig \
curl \
dhcp-client \
- diffutils \
gamin \
hdparm \
libaio \
- libxml2 \
lrzsz \
lzo \
mc \
@@ -67,7 +63,6 @@ RDEPENDS_packagegroup-core-sys-extended = "\
which \
xinetd \
zip \
- lsbinitscripts \
"
RDEPENDS_packagegroup-core-db = "\
@@ -97,48 +92,98 @@ RDEPENDS_packagegroup-core-tcl = "\
tcl \
"
-RDEPENDS_packagegroup-core-misc = "\
- elfutils \
+# Miscellaneous packages required by LSB (or LSB tests)
+RDEPENDS_packagegroup-core-lsb-misc = "\
+ chkconfig \
gettext \
gettext-runtime \
groff \
- lsb \
+ lsbinitscripts \
lsbsetup \
lsbtest \
lsof \
- man \
- man-pages \
- ncurses \
strace \
libusb1 \
usbutils \
- zlib \
+ rpm \
"
-RDEPENDS_packagegroup-core-lsb-command-add = "\
- localedef \
+SUMMARY_packagegroup-core-lsb-core = "LSB Core"
+DESCRIPTION_packagegroup-core-lsb-core = "Packages required to support commands/libraries \
+ specified in the LSB Core specification"
+RDEPENDS_packagegroup-core-lsb-core = "\
+ at \
+ bash \
+ bc \
+ binutils \
+ binutils-symlinks \
+ coreutils \
+ cpio \
+ cronie \
+ cups \
+ diffutils \
+ ed \
+ eglibc-utils \
+ elfutils \
+ file \
+ findutils \
fontconfig-utils \
+ foomatic-filters \
+ gawk \
+ ghostscript \
+ grep \
+ gzip \
+ localedef \
+ lsb \
+ m4 \
mailx \
+ make \
+ man \
+ man-pages \
+ mktemp \
msmtp \
- chkconfig \
+ patch \
+ pax \
+ procps \
+ psmisc \
+ sed \
+ shadow \
+ tar \
+ time \
+ util-linux \
xdg-utils \
- foomatic-filters \
- cups \
- ghostscript \
+ \
+ eglibc \
+ libgcc \
+ libpam \
+ libxml2 \
+ ncurses \
+ zlib \
"
-RDEPENDS_packagegroup-core-lsb-perl-add = "\
+SUMMARY_packagegroup-core-lsb-perl = "LSB Runtime Languages (Perl)"
+DESCRIPTION_packagegroup-core-lsb-perl = "Packages required to support libraries \
+ specified in the LSB Runtime languages specification (Perl parts)"
+RDEPENDS_packagegroup-core-lsb-perl = "\
+ perl \
perl-modules \
perl-misc \
perl-pod \
"
-RDEPENDS_packagegroup-core-lsb-python-add = "\
+SUMMARY_packagegroup-core-lsb-python = "LSB Runtime Languages (Python)"
+DESCRIPTION_packagegroup-core-lsb-python = "Packages required to support libraries \
+ specified in the LSB Runtime languages specification (Python parts)"
+RDEPENDS_packagegroup-core-lsb-python = "\
+ python \
python-modules \
python-misc \
"
-RDEPENDS_packagegroup-core-lsb-graphic-add = "\
+SUMMARY_packagegroup-core-lsb-desktop = "LSB Desktop"
+DESCRIPTION_packagegroup-core-lsb-desktop = "Packages required to support libraries \
+ specified in the LSB Desktop specification"
+RDEPENDS_packagegroup-core-lsb-desktop = "\
libqtcore4 \
libqtgui4 \
libqtsql4 \
@@ -181,7 +226,6 @@ RDEPENDS_packagegroup-core-lsb-runtime-add = "\
eglibc-localedata-posix \
eglibc-extra-nss \
eglibc-pcprofile \
- eglibc-utils \
"
PTH = "pth"