summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt-python_0.52.18.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-11-25 11:25:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-03 12:19:23 +0000
commit5239060e99da82134387787e544e724500a6ab41 (patch)
treec4da98381c06da4ee41746db3f3a163661641f26 /meta/recipes-extended/newt/libnewt-python_0.52.18.bb
parente884548dabab7ac1d45c469390f3238f57dbb684 (diff)
downloadopenembedded-core-contrib-5239060e99da82134387787e544e724500a6ab41.tar.gz
libnewt/libnewt-python: upgrade to 0.52.18
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt-python_0.52.18.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt-python_0.52.18.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt-python_0.52.18.bb b/meta/recipes-extended/newt/libnewt-python_0.52.18.bb
new file mode 100644
index 0000000000..d591fbd3d2
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt-python_0.52.18.bb
@@ -0,0 +1,27 @@
+require recipes-extended/newt/libnewt_${PV}.bb
+
+SUMMARY .= " - python"
+DEPENDS = "libnewt python"
+RDEPENDS_${PN} += "python-core"
+
+inherit pythonnative python-dir
+
+EXTRA_OECONF += "--with-python"
+EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
+
+
+do_compile () {
+ VERSION="$(sed -n 's/^VERSION = //p' Makefile)"
+ oe_runmake "LIBNEWTSH=${STAGING_LIBDIR}/libnewt.so.$VERSION" _snack.so
+}
+
+do_install () {
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}
+ install -m 0755 ${PYTHON_DIR}/_snack.so ${D}${PYTHON_SITEPACKAGES_DIR}/
+ install -m 0644 snack.py ${D}${PYTHON_SITEPACKAGES_DIR}/
+}
+
+PACKAGES_remove = "whiptail"
+
+FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug/"