aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mktemp
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-10-15 16:31:35 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-17 14:10:44 +0100
commit1c892e84bbe97415d5042b1c1d9b4ac8f756e041 (patch)
tree65b74f7f3179325f35c354baac1f941dcec80c04 /meta/recipes-extended/mktemp
parent576c8d181b8d702d4d6e754b3832dc2c34123257 (diff)
downloadopenembedded-core-contrib-1c892e84bbe97415d5042b1c1d9b4ac8f756e041.tar.gz
mktemp: Add patch to fix parallel make install
(From OE-Core rev: 28c7541582936c84b4c6f9de9a345d1463236167) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mktemp')
-rw-r--r--meta/recipes-extended/mktemp/files/fix-parallel-make.patch23
-rw-r--r--meta/recipes-extended/mktemp/mktemp_1.7.bb3
2 files changed, 25 insertions, 1 deletions
diff --git a/meta/recipes-extended/mktemp/files/fix-parallel-make.patch b/meta/recipes-extended/mktemp/files/fix-parallel-make.patch
new file mode 100644
index 0000000000..8c693cc151
--- /dev/null
+++ b/meta/recipes-extended/mktemp/files/fix-parallel-make.patch
@@ -0,0 +1,23 @@
+This fixes the parallel make install failure
+
+Upstream-Status: Pending
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: mktemp-1.7/Makefile.in
+===================================================================
+--- mktemp-1.7.orig/Makefile.in
++++ mktemp-1.7/Makefile.in
+@@ -94,10 +94,10 @@ install-dirs:
+ $(SHELL) $(srcdir)/mkinstalldirs $(DESTDIR)$(bindir) \
+ $(DESTDIR)$(mandir)/man1
+
+-install-binaries: $(PROG)
++install-binaries: install-dirs $(PROG)
+ $(INSTALL) -m 0555 $(PROG) $(DESTDIR)$(bindir)/$(PROG)
+
+-install-man:
++install-man: install-dirs
+ $(INSTALL) -m 0444 $(srcdir)/mktemp.$(mantype) \
+ $(DESTDIR)$(mandir)/man1/mktemp.1
+
diff --git a/meta/recipes-extended/mktemp/mktemp_1.7.bb b/meta/recipes-extended/mktemp/mktemp_1.7.bb
index d0479ced2a..65f542ef00 100644
--- a/meta/recipes-extended/mktemp/mktemp_1.7.bb
+++ b/meta/recipes-extended/mktemp/mktemp_1.7.bb
@@ -5,10 +5,11 @@ SECTION = "console/utils"
LICENSE = "ISC"
LIC_FILES_CHKSUM = "file://LICENSE;md5=430680f6322a1eb87199b5e01a82c0d4"
-PR = "r0"
+PR = "r1"
SRC_URI = "ftp://ftp.mktemp.org/pub/mktemp/${BPN}-${PV}.tar.gz \
file://disable-strip.patch \
+ file://fix-parallel-make.patch \
"
SRC_URI[md5sum] = "787bbed9fa2ee8e7645733c0e8e65172"