summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2017-05-30 10:08:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-06 19:02:43 +0100
commitff4a7a9a1d7898a214736933216dedc7055e3700 (patch)
tree28629f6a7aa0290c705f43aa9cdd42c4872ab048 /meta/recipes-extended/mdadm
parent8b66ad49a00c7bfabb0db824f727d741833f97ec (diff)
downloadopenembedded-core-contrib-ff4a7a9a1d7898a214736933216dedc7055e3700.tar.gz
recipes: Replace "cp -a" with "cp -R --no-dereference --preserve=mode, links"
* Using "cp -a" leaks UID of user running the builds, causing many QA warnings. * See this thread for details: http://lists.openembedded.org/pipermail/openembedded-core/2015-November/112904.html (From OE-Core rev: 2fcb9bee2487ba8c5e7b2c1fda2fdffcf7fb7f78) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_4.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_4.0.bb b/meta/recipes-extended/mdadm/mdadm_4.0.bb
index 98a10a8b15..506b0bc315 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.0.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.0.bb
@@ -55,7 +55,7 @@ do_compile_ptest() {
}
do_install_ptest() {
- cp -a ${S}/tests ${D}${PTEST_PATH}/tests
+ cp -R --no-dereference --preserve=mode,links -v ${S}/tests ${D}${PTEST_PATH}/tests
cp ${S}/test ${D}${PTEST_PATH}
sed -e 's!sleep 0.*!sleep 1!g; s!/var/tmp!/!g' -i ${D}${PTEST_PATH}/test
ln -s ${base_sbindir}/mdadm ${D}${PTEST_PATH}/mdadm