aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_3.3.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-04 11:39:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-06 16:41:34 +0000
commitcfd25d00575a88acc6739e12077ca593d7436436 (patch)
treed9602e4133c2af7418609707fcfd3e2986a8d7ee /meta/recipes-extended/mdadm/mdadm_3.3.2.bb
parent330c39685b5d71d4382d4b4930581de07ed689c6 (diff)
downloadopenembedded-core-contrib-cfd25d00575a88acc6739e12077ca593d7436436.tar.gz
mdadm: 3.3.1 -> 3.3.2
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_3.3.2.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.3.2.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.3.2.bb b/meta/recipes-extended/mdadm/mdadm_3.3.2.bb
new file mode 100644
index 0000000000..c9392b43f6
--- /dev/null
+++ b/meta/recipes-extended/mdadm/mdadm_3.3.2.bb
@@ -0,0 +1,45 @@
+SUMMARY = "Tool for managing software RAID under Linux"
+HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
+
+# Some files are GPLv2+ while others are GPLv2.
+LICENSE = "GPLv2 & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
+ file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
+
+
+SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \
+ file://mdadm-3.2.2_fix_for_x32.patch \
+ file://gcc-4.9.patch \
+ "
+
+SRC_URI[md5sum] = "44698d351501cac6a89072dc877eb220"
+SRC_URI[sha256sum] = "0f3a7e1a76b13892b79f9fceaf99ecb23513260389a768ac644ffa3ae06e5b8c"
+
+CFLAGS += "-fno-strict-aliasing"
+
+inherit autotools-brokensep
+
+# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
+do_configure_prepend () {
+ sed -i -e '/.*ansidecl.h.*/d' ${S}/sha1.h
+}
+
+EXTRA_OEMAKE = "CHECK_RUN_DIR=0"
+# PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h
+# prevents 64-bit userland from seeing this definition, instead defaulting
+# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
+# int-ll64.h included
+EXTRA_OEMAKE_append_powerpc64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
+EXTRA_OEMAKE_append_mips64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ export STRIP=""
+ autotools_do_install
+}
+
+FILES_${PN} += "${base_libdir}/udev/rules.d/*.rules"