aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_3.82.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-07 04:24:30 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-08 10:45:25 +0100
commitfd05945ac11a0eea9302e4fba13b6411cf2137fc (patch)
treefc9fe9cb30b684b697226b3aeeb71a4d9b63f979 /meta/recipes-extended/man-pages/man-pages_3.82.bb
parentf6962dc2d60be508f251944130f9bd1bd1e4941b (diff)
downloadopenembedded-core-contrib-fd05945ac11a0eea9302e4fba13b6411cf2137fc.tar.gz
man-pages: 3.76 -> 3.82
Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_3.82.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_3.82.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_3.82.bb b/meta/recipes-extended/man-pages/man-pages_3.82.bb
new file mode 100644
index 0000000000..7c1a7dc1c7
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_3.82.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Linux man-pages"
+DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
+SECTION = "console/utils"
+HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
+LICENSE = "GPLv2+"
+
+LIC_FILES_CHKSUM = "file://README;md5=8f2a3d43057d458e5066714980567a60"
+SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/Archive/${BP}.tar.gz"
+
+SRC_URI[md5sum] = "ce4bffb9982d197bf35b59d0a12453ca"
+SRC_URI[sha256sum] = "9c22781f485d00e6b258dcaaf1efd220fee9f8d4ce59cd881b062be06be5efe8"
+
+RDEPENDS_${PN} = "man"
+
+do_configure () {
+ :
+}
+
+do_compile() {
+ :
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+# Only deliveres man-pages so FILES_${PN} gets everything
+FILES_${PN}-doc = ""
+FILES_${PN} = "${mandir}/*"
+
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
+ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
+ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"