aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lzip/lzip_1.20.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-03-19 21:11:08 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 09:54:48 +0100
commit64fea1fcd3bd5b63937874cd07498dee66ca3748 (patch)
treef24df01b2bdc0e39fcb78efcf3e14482ee96099b /meta/recipes-extended/lzip/lzip_1.20.bb
parent8293201d98d368d6322eaa960fb3e7cee2ba9368 (diff)
downloadopenembedded-core-contrib-64fea1fcd3bd5b63937874cd07498dee66ca3748.tar.gz
lzip: upgrade 1.19 -> 1.20
Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lzip/lzip_1.20.bb')
-rw-r--r--meta/recipes-extended/lzip/lzip_1.20.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-extended/lzip/lzip_1.20.bb b/meta/recipes-extended/lzip/lzip_1.20.bb
new file mode 100644
index 0000000000..d1fc2a1da8
--- /dev/null
+++ b/meta/recipes-extended/lzip/lzip_1.20.bb
@@ -0,0 +1,41 @@
+SUMMARY = "Lossless data compressor based on the LZMA algorithm"
+HOMEPAGE = "http://lzip.nongnu.org/lzip.html"
+SECTION = "console/utils"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
+ file://decoder.cc;beginline=3;endline=16;md5=db09fe3f9573f94d0076f7f07959e6e1"
+
+SRC_URI = "${SAVANNAH_GNU_MIRROR}/lzip/lzip-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "21c1517da2ace9689fd953918660b3c3"
+SRC_URI[sha256sum] = "c93b81a5a7788ef5812423d311345ba5d3bd4f5ebf1f693911e3a13553c1290c"
+
+CONFIGUREOPTS = "\
+ '--srcdir=${S}' \
+ '--prefix=${prefix}' \
+ '--exec-prefix=${exec_prefix}' \
+ '--bindir=${bindir}' \
+ '--datadir=${datadir}' \
+ '--infodir=${infodir}' \
+ '--sysconfdir=${sysconfdir}' \
+ 'CXX=${CXX}' \
+ 'CPPFLAGS=${CPPFLAGS}' \
+ 'CXXFLAGS=${CXXFLAGS}' \
+ 'LDFLAGS=${LDFLAGS}' \
+"
+EXTRA_OEMAKE = ""
+
+B = "${S}/obj"
+do_configure () {
+ ${S}/configure ${CONFIGUREOPTS}
+}
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ # Info dir listing isn't interesting at this point so remove it if it exists.
+ if [ -e "${D}${infodir}/dir" ]; then
+ rm -f ${D}${infodir}/dir
+ fi
+}
+
+BBCLASSEXTEND = "native nativesdk"