summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp
diff options
context:
space:
mode:
authorHe Zhe <zhe.he@windriver.com>2020-01-19 16:50:48 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-19 23:49:15 +0000
commitbfffb32611c6d61286171af7f4b1b2edb227f186 (patch)
tree0a853a5c1a7a1caa5a7a6dab0bda2f0998437534 /meta/recipes-extended/ltp
parent18af9ecef6e247519d8a1573e32208bb69cf81fe (diff)
downloadopenembedded-core-contrib-bfffb32611c6d61286171af7f4b1b2edb227f186.tar.gz
ltp: Fix nm01 faliure
Backport a patch from upstream to fix the following runtime failure. The latest nm v2.33.1 outputs symbols addresses without prefix zeros for "nm -f posix", which causes the following error. nm01 5 TFAIL: Got wrong format with -f bsd Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp')
-rw-r--r--meta/recipes-extended/ltp/ltp/0001-nm01-Remove-prefix-zeros-of-the-addresses-output-by-.patch43
-rw-r--r--meta/recipes-extended/ltp/ltp_20190930.bb1
2 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp/0001-nm01-Remove-prefix-zeros-of-the-addresses-output-by-.patch b/meta/recipes-extended/ltp/ltp/0001-nm01-Remove-prefix-zeros-of-the-addresses-output-by-.patch
new file mode 100644
index 0000000000..fe5e7314e0
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/0001-nm01-Remove-prefix-zeros-of-the-addresses-output-by-.patch
@@ -0,0 +1,43 @@
+From 59cb0dd9f8e65b2d398fcaf4d163cbc8e1d0ae45 Mon Sep 17 00:00:00 2001
+From: He Zhe <zhe.he@windriver.com>
+Date: Tue, 31 Dec 2019 15:02:48 +0800
+Subject: [PATCH] nm01: Remove prefix zeros of the addresses output by nm
+ before comparing
+
+The latest nm v2.33.1 outputs symbols addresses without prefix zeros
+for "nm -f posix", which causes the following error.
+nm01 5 TFAIL: Got wrong format with -f bsd
+
+Let's remove the prefix zeros before comparing.
+
+Upstream-Status: Backport [59cb0dd9f8e65b2d398fcaf4d163cbc8e1d0ae45]
+
+Signed-off-by: He Zhe <zhe.he@windriver.com>
+Reviewed-by: Li Wang <liwang@redhat.com>
+Reviewed-by: Petr Vorel <pvorel@suse.cz>
+Tested-by: Petr Vorel <pvorel@suse.cz>
+---
+ testcases/commands/nm/nm01.sh | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/testcases/commands/nm/nm01.sh b/testcases/commands/nm/nm01.sh
+index 30c41bd..fd9d3d9 100755
+--- a/testcases/commands/nm/nm01.sh
++++ b/testcases/commands/nm/nm01.sh
+@@ -84,8 +84,11 @@ test5()
+ EXPECT_PASS $NM -f bsd $TST_DATAROOT/f1 \> nm_bsd.out
+ EXPECT_PASS $NM -f posix $TST_DATAROOT/f1 \> nm_posix.out
+
+- ROD awk '{print $3 $2 $1}' nm_bsd.out \> nm1.out
+- ROD awk '{print $1 $2 $3}' nm_posix.out \> nm2.out
++ ROD awk '{print gensub(/\y(0+)([0-9a-fA-F]+)\y/, "\\2", "g")}' nm_bsd.out \> trimmed_nm_bsd.out
++ ROD awk '{print gensub(/\y(0+)([0-9a-fA-F]+)\y/, "\\2", "g")}' nm_posix.out \> trimmed_nm_posix.out
++
++ ROD awk '{print $3 $2 $1}' trimmed_nm_bsd.out \> nm1.out
++ ROD awk '{print $1 $2 $3}' trimmed_nm_posix.out \> nm2.out
+
+ if diff nm1.out nm2.out > /dev/null; then
+ tst_res TPASS "Got BSD format with -f bsd"
+--
+2.7.4
+
diff --git a/meta/recipes-extended/ltp/ltp_20190930.bb b/meta/recipes-extended/ltp/ltp_20190930.bb
index e56bb575d2..2853b1c819 100644
--- a/meta/recipes-extended/ltp/ltp_20190930.bb
+++ b/meta/recipes-extended/ltp/ltp_20190930.bb
@@ -41,6 +41,7 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
file://0001-mkswap01.sh-Add-udevadm-trigger-before-swap-verifica.patch \
file://0001-testcases-fix-an-absent-format-string-issue.patch \
file://0001-Add-more-musl-exclusions.patch \
+ file://0001-nm01-Remove-prefix-zeros-of-the-addresses-output-by-.patch \
"
S = "${WORKDIR}/git"