summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-12-20 22:18:01 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-21 22:29:08 +0000
commit7839481de7949d59e25113937c0b8901dc5b7425 (patch)
tree5ec039d9e49ab4a8ba6e4ccfd1a8f1efe04c64dd /meta/recipes-extended/ltp
parent824713174fae0617240a236d1bbfd2929bf4b24f (diff)
downloadopenembedded-core-contrib-7839481de7949d59e25113937c0b8901dc5b7425.tar.gz
ltp: Fix ltp-pan crash on 32bit arches using 64bit time_t
ltp-pan crashes on riscv32/musl due to shorter width assigned to time_t in printf format Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp')
-rw-r--r--meta/recipes-extended/ltp/ltp/0001-ltp-pan-Use-long-long-int-to-print-time_t.patch33
-rw-r--r--meta/recipes-extended/ltp/ltp_20200930.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp/0001-ltp-pan-Use-long-long-int-to-print-time_t.patch b/meta/recipes-extended/ltp/ltp/0001-ltp-pan-Use-long-long-int-to-print-time_t.patch
new file mode 100644
index 0000000000..381ac417ca
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/0001-ltp-pan-Use-long-long-int-to-print-time_t.patch
@@ -0,0 +1,33 @@
+From 6c2085badea7b461245837c452a0d3d8a8c2afff Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 20 Dec 2020 22:09:28 -0800
+Subject: [PATCH] ltp-pan: Use long long int to print time_t
+
+Some newer 32bit architectures ( e.g. riscv32 ) uses 64bit time_t so
+using %ld is not sufficient to print time_t, this also fixes a crash in
+ltp-pan on riscv32
+
+Upstream-Status: Submitted [https://patchwork.ozlabs.org/project/ltp/patch/20201221061415.2540216-1-raj.khem@gmail.com/]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ pan/ltp-pan.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/pan/ltp-pan.c b/pan/ltp-pan.c
+index 8b9fbe5594..54b7cb8f26 100644
+--- a/pan/ltp-pan.c
++++ b/pan/ltp-pan.c
+@@ -1389,8 +1389,8 @@ static void write_test_start(struct tag_pgrp *running, int no_kmsg)
+ if (!strcmp(reporttype, "rts")) {
+
+ printf
+- ("%s\ntag=%s stime=%ld\ncmdline=\"%s\"\ncontacts=\"%s\"\nanalysis=%s\n%s\n",
+- "<<<test_start>>>", running->cmd->name, running->mystime,
++ ("%s\ntag=%s stime=%lld\ncmdline=\"%s\"\ncontacts=\"%s\"\nanalysis=%s\n%s\n",
++ "<<<test_start>>>", running->cmd->name, (long long)running->mystime,
+ running->cmd->cmdline, "", "exit", "<<<test_output>>>");
+ }
+ fflush(stdout);
+--
+2.29.2
+
diff --git a/meta/recipes-extended/ltp/ltp_20200930.bb b/meta/recipes-extended/ltp/ltp_20200930.bb
index 7acf15b360..e3c49fbf53 100644
--- a/meta/recipes-extended/ltp/ltp_20200930.bb
+++ b/meta/recipes-extended/ltp/ltp_20200930.bb
@@ -34,6 +34,7 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
file://0007-Fix-test_proc_kill-hanging.patch \
file://0001-Add-more-musl-exclusions.patch \
file://0001-Remove-OOM-tests-from-runtest-mm.patch \
+ file://0001-ltp-pan-Use-long-long-int-to-print-time_t.patch \
"
S = "${WORKDIR}/git"