summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-12-13 20:02:57 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-09 13:34:31 +0000
commit520cee660efa60e44dbf004a617c130597be6cae (patch)
tree433823748b30ee36e0abcd2fbb15491209fe1162 /meta/recipes-extended/ltp
parent97976de2a5465cb476379ebc9d9e1b3f0837853a (diff)
downloadopenembedded-core-contrib-520cee660efa60e44dbf004a617c130597be6cae.tar.gz
ltp: fix build for x32
We need to use the correct time() definition with time_t rather than a long, since long is 32-bit on x32. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/ltp')
-rw-r--r--meta/recipes-extended/ltp/ltp/fcntl-fix-the-time-def-to-use-time_t.patch28
-rw-r--r--meta/recipes-extended/ltp/ltp_20160126.bb1
2 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp/fcntl-fix-the-time-def-to-use-time_t.patch b/meta/recipes-extended/ltp/ltp/fcntl-fix-the-time-def-to-use-time_t.patch
new file mode 100644
index 0000000000..f7e805a954
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/fcntl-fix-the-time-def-to-use-time_t.patch
@@ -0,0 +1,28 @@
+From 9590d073d3abe02fe0783ef8c530aef2e873ba9b Mon Sep 17 00:00:00 2001
+From: Christopher Larson <chris_larson@mentor.com>
+Date: Tue, 13 Dec 2016 12:48:29 -0700
+Subject: [PATCH] fcntl: fix the time() def to use time_t
+
+This fixes the build on X32, where long is 32-bit rather than 64-bit.
+
+Signed-off-by: Christopher Larson <chris_larson@mentor.com>
+---
+ testcases/kernel/syscalls/fcntl/fcntl14.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/testcases/kernel/syscalls/fcntl/fcntl14.c b/testcases/kernel/syscalls/fcntl/fcntl14.c
+index 3b36572..65ac8fa 100644
+--- a/testcases/kernel/syscalls/fcntl/fcntl14.c
++++ b/testcases/kernel/syscalls/fcntl/fcntl14.c
+@@ -789,7 +789,7 @@ void dochild(void)
+
+ void run_test(int file_flag, int file_mode, int seek, int start, int end)
+ {
+- extern long time();
++ extern time_t time();
+
+ /* reset fail to 0 for each run_test call */
+ fail = 0;
+--
+2.8.0
+
diff --git a/meta/recipes-extended/ltp/ltp_20160126.bb b/meta/recipes-extended/ltp/ltp_20160126.bb
index 6e2ceac0e2..72d465bed3 100644
--- a/meta/recipes-extended/ltp/ltp_20160126.bb
+++ b/meta/recipes-extended/ltp/ltp_20160126.bb
@@ -65,6 +65,7 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
file://0036-testcases-network-nfsv4-acl-acl1.c-Security-fix-on-s.patch \
file://0037-containers-netns_netlink-Avoid-segmentation-fault.patch \
file://0038-run-posix-option-group-test-replace-CWD-qith-PWD.patch \
+ file://fcntl-fix-the-time-def-to-use-time_t.patch \
"
S = "${WORKDIR}/git"