summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp
diff options
context:
space:
mode:
authorHe Zhe <zhe.he@windriver.com>2019-04-22 16:55:39 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-03 09:09:50 +0100
commit3602a7affd95a22e7e22c9ed4df731f94ed9b64b (patch)
treeb9cce640a5769cc0a11e03c5193c0c2fd71bb90b /meta/recipes-extended/ltp
parentedf760682270de36850407c860bea5aea29e30bc (diff)
downloadopenembedded-core-contrib-3602a7affd95a22e7e22c9ed4df731f94ed9b64b.tar.gz
ltp: file01: Fix in was not recognized
Some file has "pie" appending after LSB or MSB, which causes mismatch and the following error. "file01 10 TFAIL: in: was not recognized" ..."ELF 64-bit LSB pie executable"... This patches tunes the regulation expression to include those cases. Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp')
-rw-r--r--meta/recipes-extended/ltp/ltp/0001-file01.sh-Fix-in-was-not-recognized.patch38
-rw-r--r--meta/recipes-extended/ltp/ltp_20190115.bb3
2 files changed, 40 insertions, 1 deletions
diff --git a/meta/recipes-extended/ltp/ltp/0001-file01.sh-Fix-in-was-not-recognized.patch b/meta/recipes-extended/ltp/ltp/0001-file01.sh-Fix-in-was-not-recognized.patch
new file mode 100644
index 0000000000..5cd9e082f2
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/0001-file01.sh-Fix-in-was-not-recognized.patch
@@ -0,0 +1,38 @@
+From 974e9b862e503c50501079e6586f81918e94a849 Mon Sep 17 00:00:00 2001
+From: He Zhe <zhe.he@windriver.com>
+Date: Fri, 19 Apr 2019 17:57:48 +0800
+Subject: [PATCH] file01.sh: Fix in was not recognized
+
+Some file has "pie" appending after LSB or MSB, which causes mismatch and the
+following error.
+
+"file01 10 TFAIL: in: was not recognized"
+..."ELF 64-bit LSB pie executable"...
+
+This patches tunes the regulation expression to include those cases.
+
+Upstream-Status: Submitted [http://lists.linux.it/pipermail/ltp/2019-April/011758.html]
+
+Signed-off-by: He Zhe <zhe.he@windriver.com>
+---
+ testcases/commands/file/file01.sh | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/testcases/commands/file/file01.sh b/testcases/commands/file/file01.sh
+index 0a8119e..55c0433 100755
+--- a/testcases/commands/file/file01.sh
++++ b/testcases/commands/file/file01.sh
+@@ -91,7 +91,9 @@ do_test()
+ 9) file_test in.m4 "M4 macro processor script, ASCII text" \
+ "ASCII M4 macro language pre-processor text";;
+ 10) file_test in "ELF .*-bit $TEST_ARCH executable, .*" \
+- "ELF .*-bit $TEST_ARCH shared object, .*";;
++ "ELF .*-bit $TEST_ARCH shared object, .*" \
++ "ELF .*-bit $TEST_ARCH pie executable, .*" \
++ "ELF .*-bit $TEST_ARCH pie shared object, .*";;
+ 11) file_test in.ar "current ar archive";;
+ 12) file_test in.tar "tar archive";;
+ 13) file_test in.tar.gz "gzip compressed data, .*";;
+--
+2.7.4
+
diff --git a/meta/recipes-extended/ltp/ltp_20190115.bb b/meta/recipes-extended/ltp/ltp_20190115.bb
index b8a7e673d3..b7b581f65a 100644
--- a/meta/recipes-extended/ltp/ltp_20190115.bb
+++ b/meta/recipes-extended/ltp/ltp_20190115.bb
@@ -51,7 +51,8 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
file://setregid01-security-string-formatting.patch \
file://0001-syscalls-setrlimit03.c-read-proc-sys-fs-nr_open-for-.patch \
file://0001-shmctl01-don-t-use-hardcoded-index-0-for-SHM_STAT-te.patch \
- file://0001-diotest4-Let-kernel-pick-an-address-when-calling-mma.patch\
+ file://0001-diotest4-Let-kernel-pick-an-address-when-calling-mma.patch \
+ file://0001-file01.sh-Fix-in-was-not-recognized.patch \
"
S = "${WORKDIR}/git"