aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-01-15 14:10:54 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-15 17:26:50 +0000
commitcea75f9c8c083d76ad8c45127be332665ef09d06 (patch)
tree44ac698747ffd2fcc960e11c1c06ec7e67df86d4 /meta/recipes-extended/ltp
parent375ac7268dc24730373d40169231cde1f93dadfb (diff)
downloadopenembedded-core-contrib-cea75f9c8c083d76ad8c45127be332665ef09d06.tar.gz
ltp: fix makefile race
There is a Makefile dependency race causing occasional build failures: *** No rule to make target `.../work/core2-poky-linux/ltp/20130904-r0/git/testcases/kernel/include/linux_syscall_numbers.h.23161.sh', needed by `linux_syscall_numbers.h'. Stop. This is due to a bad dependency wildcard that is matching more than the one file it should match, so replace it with a concrete filename. (From OE-Core rev: 639ecfb578ff926f5deddb984f4f8600e161e22a) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp')
-rw-r--r--meta/recipes-extended/ltp/ltp/regen-makefile.patch22
-rw-r--r--meta/recipes-extended/ltp/ltp_20130904.bb1
2 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp/regen-makefile.patch b/meta/recipes-extended/ltp/ltp/regen-makefile.patch
new file mode 100644
index 0000000000..3e114a1d85
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/regen-makefile.patch
@@ -0,0 +1,22 @@
+Fix the dependencies for linux_syscall_numbers.h where in a parallel build it was
+finding the temporary file linux_syscall_numbers.h.[pid].sh (where sh is an
+architecture name). Instead don't wildcard *.sh as the only .sh we care about
+here is regen.sh, so hard-code that.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/testcases/kernel/include/Makefile b/testcases/kernel/include/Makefile
+index db21a2a..585eb5e 100644
+--- a/testcases/kernel/include/Makefile
++++ b/testcases/kernel/include/Makefile
+@@ -28,7 +28,7 @@ INSTALL_DIR := $(includedir)
+
+ MAKE_TARGETS := linux_syscall_numbers.h
+
+-linux_syscall_numbers.h: $(wildcard $(abs_srcdir)/*.sh $(abs_srcdir)/*.in)
+- $(SHELL) "$(abs_srcdir)/regen.sh"
++linux_syscall_numbers.h: $(abs_srcdir)/regen.sh $(wildcard $(abs_srcdir)/*.in)
++ $(SHELL) "$<"
+
+ include $(top_srcdir)/include/mk/generic_leaf_target.mk
diff --git a/meta/recipes-extended/ltp/ltp_20130904.bb b/meta/recipes-extended/ltp/ltp_20130904.bb
index 4722a38bce..c346c5ccb8 100644
--- a/meta/recipes-extended/ltp/ltp_20130904.bb
+++ b/meta/recipes-extended/ltp/ltp_20130904.bb
@@ -23,6 +23,7 @@ DEPENDS = "attr libaio libcap acl openssl"
SRC_URI = "git://github.com/linux-test-project/ltp.git \
file://0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch \
+ file://regen-makefile.patch \
"
SRCREV = "a8c42db5f9314211811c36275a21f83902830dc5"