aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2014-01-28 14:41:54 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-02 11:22:09 +0000
commit81325a412b1983ba7af92ef141fd471e37d6a448 (patch)
treecf8e5ab35330abdcc188e9bdb2cf6a4691989904 /meta/recipes-extended/ltp
parent815261a9277e2027ac92b3e229a07b8f9103695e (diff)
downloadopenembedded-core-contrib-81325a412b1983ba7af92ef141fd471e37d6a448.tar.gz
ltp: fix ffsb ftbfs on cross-compiled environment
Add ffsb-remove-hardcoded-configure.patch: get rid of the hardcoded configure call preventing cross-compilation Add do_configure_prepend to explicitly force regeneration the configure file and pass configure options as appropriate. (From OE-Core rev: ce48f4ebfeae0bca599c6e39958ec8dec11e09dd) Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp')
-rw-r--r--meta/recipes-extended/ltp/ltp/ffsb-remove-hardcoded-configure.patch15
-rw-r--r--meta/recipes-extended/ltp/ltp_20140115.bb7
2 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp/ffsb-remove-hardcoded-configure.patch b/meta/recipes-extended/ltp/ltp/ffsb-remove-hardcoded-configure.patch
new file mode 100644
index 0000000000..9f02711070
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/ffsb-remove-hardcoded-configure.patch
@@ -0,0 +1,15 @@
+Get rid of the hardcoded configure call preventing cross-compilation
+
+Upstream-Status: Pending
+Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
+
+--- a/utils/Makefile
++++ b/utils/Makefile
+@@ -29,7 +29,6 @@ FILTER_OUT_DIRS := $(FFSBDIR)
+ FFSB := $(FFSBDIR)/ffsb
+
+ $(FFSB): $(FFSBDIR)
+- cd $^; ./configure
+ $(MAKE) -C $^ -f "$(abs_srcdir)/$^/Makefile" all
+ cp $(FFSBDIR)/ffsb ffsb
+
diff --git a/meta/recipes-extended/ltp/ltp_20140115.bb b/meta/recipes-extended/ltp/ltp_20140115.bb
index 4e20f24cce..2ab1d50a3e 100644
--- a/meta/recipes-extended/ltp/ltp_20140115.bb
+++ b/meta/recipes-extended/ltp/ltp_20140115.bb
@@ -25,6 +25,7 @@ SRCREV = "c8b3e28097e7d3208df9daceaf92c25eae87ebf0"
SRC_URI = "git://github.com/linux-test-project/ltp.git \
file://0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch \
file://regen-makefile.patch \
+ file://ffsb-remove-hardcoded-configure.patch \
"
S = "${WORKDIR}/git"
@@ -36,6 +37,12 @@ TARGET_CC_ARCH += "${LDFLAGS}"
export prefix = "/opt/ltp"
export exec_prefix = "/opt/ltp"
+# ltp doesn't regenerate ffsb-6.0-rc2 configure and hardcode configure call.
+# we explicitly force regeneration of that directory and pass configure options.
+do_configure_prepend() {
+ (cd utils/ffsb-6.0-rc2; autoreconf -fvi; ./configure ${CONFIGUREOPTS})
+}
+
do_install(){
install -d ${D}/opt/ltp/
oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install