aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2016-04-01 13:46:20 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-03 15:51:35 +0100
commit46eed0a4aaac943fff9cdba81848a9e0b1154b5c (patch)
tree7ae96fb2b941517b3cbfc6c36557d726de33f81e /meta/recipes-extended/ltp
parent207ee90595a4e36c7358db7920562ad19ecb4179 (diff)
downloadopenembedded-core-contrib-46eed0a4aaac943fff9cdba81848a9e0b1154b5c.tar.gz
ltp: fix test_proc_kill hanging
(From OE-Core rev: 725aad58b917533d5f60bc5a8968ac89038ef219) Signed-off-by: Tudor Florea <tudor.florea@enea.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp')
-rw-r--r--meta/recipes-extended/ltp/ltp/0035-fix-test_proc_kill-hang.patch23
-rw-r--r--meta/recipes-extended/ltp/ltp_20160126.bb1
2 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp/0035-fix-test_proc_kill-hang.patch b/meta/recipes-extended/ltp/ltp/0035-fix-test_proc_kill-hang.patch
new file mode 100644
index 0000000000..32ae8aa271
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/0035-fix-test_proc_kill-hang.patch
@@ -0,0 +1,23 @@
+Fix test_proc_kill hanging
+
+Sometimes the signal is delivered to memcg_process before the framework took
+into consideration its pid entered in the tasks. Fixed by delaying the signal
+send command.
+
+Signed-off-by: George Nita <george.nita@enea.com>
+Upstream-Status: Pending
+
+diff --git a/testcases/kernel/controllers/memcg/functional/memcg_lib.sh b/testcases/kernel/controllers/memcg/functional/memcg_lib.sh
+index ffbe006..e81bf74 100755
+--- a/testcases/kernel/controllers/memcg/functional/memcg_lib.sh
++++ b/testcases/kernel/controllers/memcg/functional/memcg_lib.sh
+@@ -220,8 +220,8 @@ test_proc_kill()
+
+ $TEST_PATH/memcg_process $2 -s $3 &
+ pid=$!
+- sleep 1
+ echo $pid > tasks
++ sleep 1
+
+ kill -s USR1 $pid 2> /dev/null
+ sleep 1
diff --git a/meta/recipes-extended/ltp/ltp_20160126.bb b/meta/recipes-extended/ltp/ltp_20160126.bb
index 6be2187eaa..097c16d570 100644
--- a/meta/recipes-extended/ltp/ltp_20160126.bb
+++ b/meta/recipes-extended/ltp/ltp_20160126.bb
@@ -61,6 +61,7 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
file://0032-regen.sh-Include-asm-unistd.h-explicitly.patch \
file://0033-shmat1-Cover-GNU-specific-code-under-__USE_GNU.patch \
file://0034-periodic_output.patch \
+ file://0035-fix-test_proc_kill-hang.patch \
"
S = "${WORKDIR}/git"