summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp_20210121.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-01 21:28:58 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-02 20:35:08 +0000
commit0f51f9a37e5d058bce28cfe7b9a32a895f83c091 (patch)
tree6806273d7e85bc9f6b235445a2e1ccc0c02bf831 /meta/recipes-extended/ltp/ltp_20210121.bb
parentffc4de47988ccf7568eecc8a27e8964beeaaacfb (diff)
downloadopenembedded-core-contrib-0f51f9a37e5d058bce28cfe7b9a32a895f83c091.tar.gz
ltp: Fixing determinism issues
Add a patch adding sorting to a couple of points in the Makefiles which removes most of the determinism issues in ltp. Build swapon before the main build to ensure libswapon.o is built deterministically as it races with swapoff. All issues reported on the upstream mailing list. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20210121.bb')
-rw-r--r--meta/recipes-extended/ltp/ltp_20210121.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20210121.bb b/meta/recipes-extended/ltp/ltp_20210121.bb
index c541f9859f..593f07087c 100644
--- a/meta/recipes-extended/ltp/ltp_20210121.bb
+++ b/meta/recipes-extended/ltp/ltp_20210121.bb
@@ -29,11 +29,16 @@ CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
SRCREV = "4d005621edd109d119627eb9210b224a63bf22cb"
+# remove at next version upgrade or when output changes
+PR = "r1"
+HASHEQUIV_HASH_VERSION .= ".1"
+
SRC_URI = "git://github.com/linux-test-project/ltp.git \
file://0001-build-Add-option-to-select-libc-implementation.patch \
file://0007-Fix-test_proc_kill-hanging.patch \
file://0001-Add-more-musl-exclusions.patch \
file://0001-Remove-OOM-tests-from-runtest-mm.patch \
+ file://determinism.patch \
"
S = "${WORKDIR}/git"
@@ -51,6 +56,14 @@ EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
# ltp network/rpc test cases ftbfs when libtirpc is found
EXTRA_OECONF += " --without-tirpc "
+do_compile_prepend() {
+ # Reported at http://lists.linux.it/pipermail/ltp/2021-March/021274.html
+ # Avoid a race over construction of libswapon.o which is built by swapon and swapoff
+ # but the object differs depending upon which one built it
+ # ("../swapon/libswapon.c" vs "libswapon.c" references)
+ make -C ${B}/testcases/kernel/syscalls/swapon/
+}
+
do_install(){
install -d ${D}${prefix}/
oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install