aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2012-06-05 21:51:17 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-05 23:01:30 +0100
commit13e52fafae0fb06b26d179a5cac6898babbadc51 (patch)
tree948678ab422e357a4ca551f36d86eb8fac534bef /meta/recipes-extended/ltp/ltp
parentf7a1fdfd82be60b92f4aa4a53fdae3192d1cec8b (diff)
downloadopenembedded-core-contrib-13e52fafae0fb06b26d179a5cac6898babbadc51.tar.gz
ltp: Add patch to correct failing build
ltp makefile does not interpret correctly the result of git describe command and assumes that it is working with a git repo, while in fact working with a source code archive. Added a patch to corect makefile system. Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp/ltp')
-rw-r--r--meta/recipes-extended/ltp/ltp/fix_building_fom_archive.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp/fix_building_fom_archive.patch b/meta/recipes-extended/ltp/ltp/fix_building_fom_archive.patch
new file mode 100644
index 0000000000..a8064cfd79
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/fix_building_fom_archive.patch
@@ -0,0 +1,13 @@
+Index: ltp-20120401/Makefile
+===================================================================
+--- ltp-20120401.orig/Makefile
++++ ltp-20120401/Makefile
+@@ -173,7 +173,7 @@ SRCDIR_INSTALL_TARGETS := $(SRCDIR_INSTA
+ #
+ .PHONY: Version
+ Version:
+- if git describe &> /dev/null; then \
++ if git describe > /dev/null 2>&1; then \
+ git describe > "$@"; \
+ else \
+ cp VERSION "$@"; \