summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp/determinism2.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-05 23:20:47 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-06 22:34:13 +0000
commit636f4d1f6ed8a95e3a583abc5904ab8dbc6184af (patch)
tree77895612be66206240e68520c707a09efd81e52a /meta/recipes-extended/ltp/ltp/determinism2.patch
parent6db24928d62aeb093a0e6da6619713eaca57a96f (diff)
downloadopenembedded-core-contrib-636f4d1f6ed8a95e3a583abc5904ab8dbc6184af.tar.gz
ltp: Fix another determinism issue
After the other fixes there remained occasional problems. Fix another makefile sorting problem affecting the disktest binary. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp/ltp/determinism2.patch')
-rw-r--r--meta/recipes-extended/ltp/ltp/determinism2.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp/determinism2.patch b/meta/recipes-extended/ltp/ltp/determinism2.patch
new file mode 100644
index 0000000000..ab08e8e517
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/determinism2.patch
@@ -0,0 +1,24 @@
+testcases/kernel/io/disktest: Fix determinism issue
+
+The order of the objects linked into the test varies depending on the
+order of the files found on disk. This results in the disktest binary
+differing depending on that order.
+
+Sort the wildcard expansion of *.c which leads to reproducible binaries.
+
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+Upstream-Status: Pending
+
+Index: git/testcases/kernel/io/disktest/Makefile
+===================================================================
+--- git.orig/testcases/kernel/io/disktest/Makefile
++++ git/testcases/kernel/io/disktest/Makefile
+@@ -209,7 +209,7 @@ LDLIBS += -lpthread
+
+ MAKE_TARGETS := disktest
+
+-OBJS := $(patsubst $(abs_srcdir)/%.c,%.o,$(wildcard $(abs_srcdir)/*.c))
++OBJS := $(patsubst $(abs_srcdir)/%.c,%.o,$(sort $(wildcard $(abs_srcdir)/*.c)))
+
+ disktest-$(VER):
+ mkdir -p "$@"