aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2013-11-13 16:27:33 +0800
committerSaul Wold <sgw@linux.intel.com>2013-12-17 09:05:14 -0800
commitf9c37768caf7edf9343f76f16fa5fd4e7cd772c1 (patch)
treee729c9a570e6cc3f02eec547bff10689ecb6a872 /meta/recipes-extended/lsb
parentb226ab4cf7779f4dfaa78210cb6249766ed564c1 (diff)
downloadopenembedded-core-contrib-f9c37768caf7edf9343f76f16fa5fd4e7cd772c1.tar.gz
lsb: update directory of install_initd and remove_initd
According to LSB specification: http://refspecs.linuxfoundation.org/LSB_4.1.0/LSB-Core-generic/LSB-Core-generic/installinitd.html http://refspecs.linuxfoundation.org/LSB_4.1.0/LSB-Core-generic/LSB-Core-generic/removeinitd.html commands install_initd and remove_initd should under directory /usr/lib/lsb/. lsb recipe creates these commands under directory ${libdir} which may expand to /usr/lib64 when multilib is enabled on qemux86-64. That will cause LSB command check for install_initd and remove_initd fail. So correct it. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/lsb')
-rw-r--r--meta/recipes-extended/lsb/lsb_4.1.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta/recipes-extended/lsb/lsb_4.1.bb b/meta/recipes-extended/lsb/lsb_4.1.bb
index c80ff593c7..ecb4dcc064 100644
--- a/meta/recipes-extended/lsb/lsb_4.1.bb
+++ b/meta/recipes-extended/lsb/lsb_4.1.bb
@@ -78,9 +78,10 @@ do_install_append(){
install -m 0755 ${WORKDIR}/init-functions ${D}/${baselib}/lsb
# creat links for LSB test
- install -d ${D}/${libdir}/lsb
- ln -sf ${sbindir}/chkconfig ${D}/${libdir}/lsb/install_initd
- ln -sf ${sbindir}/chkconfig ${D}/${libdir}/lsb/remove_initd
+ install -d ${D}/usr/lib/lsb
+ ln -sf ${sbindir}/chkconfig ${D}/usr/lib/lsb/install_initd
+ ln -sf ${sbindir}/chkconfig ${D}/usr/lib/lsb/remove_initd
+ install -d ${D}/${libdir}
ln -sf ${sbindir}/sendmail ${D}/${libdir}/sendmail
if [ "${TARGET_ARCH}" = "x86_64" ];then
@@ -114,6 +115,7 @@ do_install_append(){
fi
}
FILES_${PN} += "/lib64 \
+ /usr/lib/lsb \
${base_libdir}/lsb/* \
${libdir}/sendmail \
"