aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libuser
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2012-12-10 17:37:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-13 15:18:42 +0000
commitb81f4273e68fdf677d6776f5572ad24f6ab333d9 (patch)
treec125609b79f3592aff5f1a0711e91e8a646b80eb /meta/recipes-extended/libuser
parent505f88fd3e169b3481c2bb2afbef535db00d095f (diff)
downloadopenembedded-core-contrib-b81f4273e68fdf677d6776f5572ad24f6ab333d9.tar.gz
libuser: enable python support
Compile libuser with python support and add python to DEPENDS. (From OE-Core rev: 57114b3f631b66edf136bcc7ba23eec7c7bc9970) Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/libuser')
-rw-r--r--meta/recipes-extended/libuser/libuser_0.57.1.bb14
1 files changed, 10 insertions, 4 deletions
diff --git a/meta/recipes-extended/libuser/libuser_0.57.1.bb b/meta/recipes-extended/libuser/libuser_0.57.1.bb
index 99b661b978..105bacfdd2 100644
--- a/meta/recipes-extended/libuser/libuser_0.57.1.bb
+++ b/meta/recipes-extended/libuser/libuser_0.57.1.bb
@@ -15,10 +15,16 @@ SRC_URI = "https://fedorahosted.org/releases/l/i/libuser/libuser-${PV}.tar.xz"
SRC_URI[md5sum] = "be82c6941264d0b4bd04f95fb342ec7d"
SRC_URI[sha256sum] = "a61289867581fa715354a3fafe09c3e481173ce0a2dcb33b04588b6ac13cead5"
-PR = "r2"
+PR = "r3"
-DEPENDS = "popt libpam glib-2.0 xz-native docbook-utils-native linuxdoc-tools-native"
+DEPENDS = "popt libpam glib-2.0 xz-native docbook-utils-native linuxdoc-tools-native python"
-EXTRA_OECONF += "--without-python"
+inherit autotools gettext pythonnative python-dir
+
+EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}"
+
+PACKAGES += "${PN}-python "
+
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug"
+FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
-inherit autotools gettext