aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libtirpc/libtirpc_0.2.2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-06-23 15:39:47 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-28 13:49:39 +0100
commit42a521b28817cc8d905a93a82e02481a8968cd26 (patch)
tree553e12092f89c2c39151228b73296368878edf2e /meta/recipes-extended/libtirpc/libtirpc_0.2.2.bb
parent3244e21b0d4bd7472330d058b97dc62ea79e0ef9 (diff)
downloadopenembedded-core-contrib-42a521b28817cc8d905a93a82e02481a8968cd26.tar.gz
libtirpc: Upgrade 0.2.1 -> 0.2.2
Additionally bring in the nis headers which will be required when using eglibc 2.14 where rpc support is removed. Make it provide virtual/librpc Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-extended/libtirpc/libtirpc_0.2.2.bb')
-rw-r--r--meta/recipes-extended/libtirpc/libtirpc_0.2.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-extended/libtirpc/libtirpc_0.2.2.bb b/meta/recipes-extended/libtirpc/libtirpc_0.2.2.bb
new file mode 100644
index 0000000000..f1f66e3ebf
--- /dev/null
+++ b/meta/recipes-extended/libtirpc/libtirpc_0.2.2.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Transport-Independent RPC library"
+DESCRIPTION = "Libtirpc is a port of Suns Transport-Independent RPC library to Linux"
+SECTION = "libs/network"
+PRIORITY = "optional"
+HOMEPAGE = "http://sourceforge.net/projects/libtirpc/"
+BUGTRACKER = "http://sourceforge.net/tracker/?group_id=183075&atid=903784"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f835cce8852481e4b2bbbdd23b5e47f3 \
+ file://src/netname.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24"
+PR = "r0"
+
+DEPENDS += "xz-native"
+PROVIDES = "virtual/librpc"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tar.bz2;name=libtirpc \
+ ${GENTOO_MIRROR}/${PN}-glibc-nfs.tar.xz;name=glibc-nfs \
+ file://libtirpc-0.2.1-fortify.patch \
+ file://libtirpc-0.2.2-rpc-des-prot.patch \
+ file://remove-des-crypt.patch \
+ "
+SRC_URI[libtirpc.md5sum] = "74c41c15c2909f7d11d9c7bfa7db6273"
+SRC_URI[libtirpc.sha256sum] = "f05eb17c85d62423858b8f74512cfe66a9ae1cedf93f03c2a0a32e04f0a33705"
+SRC_URI[glibc-nfs.md5sum] = "5ae500b9d0b6b72cb875bc04944b9445"
+SRC_URI[glibc-nfs.sha256sum] = "2677cfedf626f3f5a8f6e507aed5bb8f79a7453b589d684dbbc086e755170d83"
+inherit autotools pkgconfig
+
+do_configure_prepend () {
+ cp -r ${S}/../tirpc ${S}
+}
+
+do_install_append() {
+ chown root:root ${D}${sysconfdir}/netconfig
+}