summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libsolv
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2017-10-02 07:25:42 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-08 22:23:43 +0000
commit24fdebbbfdeadcf3d152a0adf3058c714b193a8f (patch)
tree7419d0e39f8ab07fd82df3d316f6b5e45451e7cd /meta/recipes-extended/libsolv
parent44af4f20bfb1fe853ed0b5dfc76bdd2900f47cb0 (diff)
downloadopenembedded-core-contrib-24fdebbbfdeadcf3d152a0adf3058c714b193a8f.tar.gz
libsolv: fix a kernel-devsrc installation issue
We encountered a problem when installing kernel-devsrc package on a intel-x86 target, as follows: $ dnf install kernel-devsrc | Installing : kernel-devsrc-1.0-r0.0.intel_corei7_64 1/1 | failed loading RPMDB | The downloaded packages were saved in cache until the next successful transaction. | You can remove cached packages by executing 'dnf clean packages'. It can be fixed by increasing MAX_HDR_CNT and MAX_HDR_DSIZE in libsolv per test. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/libsolv')
-rw-r--r--meta/recipes-extended/libsolv/libsolv/0001-repo_rpmdb.c-increase-MAX_HDR_CNT-and-MAX_HDR_DSIZE.patch35
-rw-r--r--meta/recipes-extended/libsolv/libsolv_0.6.28.bb3
2 files changed, 37 insertions, 1 deletions
diff --git a/meta/recipes-extended/libsolv/libsolv/0001-repo_rpmdb.c-increase-MAX_HDR_CNT-and-MAX_HDR_DSIZE.patch b/meta/recipes-extended/libsolv/libsolv/0001-repo_rpmdb.c-increase-MAX_HDR_CNT-and-MAX_HDR_DSIZE.patch
new file mode 100644
index 0000000000..4a4e5cba25
--- /dev/null
+++ b/meta/recipes-extended/libsolv/libsolv/0001-repo_rpmdb.c-increase-MAX_HDR_CNT-and-MAX_HDR_DSIZE.patch
@@ -0,0 +1,35 @@
+From 1c4c935cb73ac1ccb9693df1a51ba218a22e8ca8 Mon Sep 17 00:00:00 2001
+From: Ming Liu <liu.ming50@gmail.com>
+Date: Sat, 30 Sep 2017 11:15:16 +0800
+Subject: [PATCH] repo_rpmdb.c: increase MAX_HDR_CNT and MAX_HDR_DSIZE
+
+Upstream-Status: Submitted [https://github.com/openSUSE/libsolv/pull/230]
+
+We encountered 'corrupt rpm' issues when installing extreme big RPM
+packages like the kernel-devsrc package of Yocto project.
+
+It can be fixed by increasing MAX_HDR_CNT and MAX_HDR_DSIZE per test.
+
+Signed-off-by: Ming Liu <liu.ming50@gmail.com>
+---
+ ext/repo_rpmdb.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ext/repo_rpmdb.c b/ext/repo_rpmdb.c
+index c7000a9..7000835 100644
+--- a/ext/repo_rpmdb.c
++++ b/ext/repo_rpmdb.c
+@@ -170,8 +170,8 @@
+ #define MAX_SIG_CNT 0x100000
+ #define MAX_SIG_DSIZE 0x100000
+
+-#define MAX_HDR_CNT 0x100000
+-#define MAX_HDR_DSIZE 0x2000000
++#define MAX_HDR_CNT 0x200000
++#define MAX_HDR_DSIZE 0x4000000
+
+ typedef struct rpmhead {
+ int cnt;
+--
+2.7.4
+
diff --git a/meta/recipes-extended/libsolv/libsolv_0.6.28.bb b/meta/recipes-extended/libsolv/libsolv_0.6.28.bb
index 3a48f22b5f..6c8f7fc73b 100644
--- a/meta/recipes-extended/libsolv/libsolv_0.6.28.bb
+++ b/meta/recipes-extended/libsolv/libsolv_0.6.28.bb
@@ -8,7 +8,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
DEPENDS = "expat zlib rpm"
SRC_URI = "git://github.com/openSUSE/libsolv.git \
- "
+ file://0001-repo_rpmdb.c-increase-MAX_HDR_CNT-and-MAX_HDR_DSIZE.patch \
+ "
SRC_URI_append_libc-musl = " file://0001-Add-fallback-fopencookie-implementation.patch \
file://0002-Fixes-to-internal-fopencookie-implementation.patch \
"