aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libsolv/libsolv_0.7.2.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-12-20 16:43:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-08 13:27:16 +0000
commit5b0d21e4b369821235d5b1d00a578b2dca5c5d09 (patch)
treea7842f90b38a530df6d6af1ed5b8ca79c82ba611 /meta/recipes-extended/libsolv/libsolv_0.7.2.bb
parent31e6d08f20a804fccb958e19045d8f9e9806071a (diff)
downloadopenembedded-core-contrib-5b0d21e4b369821235d5b1d00a578b2dca5c5d09.tar.gz
libsolv: upgrade 0.7.1 -> 0.7.2
>From NEWS: - bug fixes: * do not autouninstall packages because of forcebest updates - new features: * support rpm's new '^' version separator * support set/get_considered_list in bindings * new experimental SOLVER_FLAG_ONLY_NAMESPACE_RECOMMENDED flag Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/libsolv/libsolv_0.7.2.bb')
-rw-r--r--meta/recipes-extended/libsolv/libsolv_0.7.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-extended/libsolv/libsolv_0.7.2.bb b/meta/recipes-extended/libsolv/libsolv_0.7.2.bb
new file mode 100644
index 0000000000..6e3993b05e
--- /dev/null
+++ b/meta/recipes-extended/libsolv/libsolv_0.7.2.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Library for solving packages and reading repositories"
+HOMEPAGE = "https://github.com/openSUSE/libsolv"
+BUGTRACKER = "https://github.com/openSUSE/libsolv/issues"
+SECTION = "devel"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
+
+DEPENDS = "expat zlib"
+
+SRC_URI = "git://github.com/openSUSE/libsolv.git"
+SRC_URI_append_libc-musl = " file://0001-Add-fallback-fopencookie-implementation.patch \
+ file://0002-Fixes-to-internal-fopencookie-implementation.patch \
+ "
+
+SRCREV = "1c0141962a9eef7f4bc1fdcac7099f3f6a95ec23"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+PACKAGECONFIG ??= "rpm"
+PACKAGECONFIG[rpm] = "-DENABLE_RPMMD=ON -DENABLE_RPMDB=ON,,rpm"
+
+EXTRA_OECMAKE = "-DLIB=${baselib} -DMULTI_SEMANTICS=ON -DENABLE_COMPLEX_DEPS=ON"
+
+PACKAGES =+ "${PN}-tools ${PN}ext"
+
+FILES_${PN}-tools = "${bindir}/*"
+FILES_${PN}ext = "${libdir}/${PN}ext.so.*"
+
+BBCLASSEXTEND = "native nativesdk"