aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libsolv/libsolv_0.6.23.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-07-27 16:02:50 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-01 11:46:35 +0100
commit55fa3dab693cd1ebb37330fc1faead3402ac23c9 (patch)
tree6ae87477834db67afa92f8c123656e2b538ab8ed /meta/recipes-extended/libsolv/libsolv_0.6.23.bb
parent5bdc7dd6a17e217abed14d00d77c4447b2568d19 (diff)
downloadopenembedded-core-contrib-55fa3dab693cd1ebb37330fc1faead3402ac23c9.tar.gz
libsolv: upgrade to 0.6.23
0.6.22 -> 0.6.23 Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/libsolv/libsolv_0.6.23.bb')
-rw-r--r--meta/recipes-extended/libsolv/libsolv_0.6.23.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-extended/libsolv/libsolv_0.6.23.bb b/meta/recipes-extended/libsolv/libsolv_0.6.23.bb
new file mode 100644
index 0000000000..1ece5f21a4
--- /dev/null
+++ b/meta/recipes-extended/libsolv/libsolv_0.6.23.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Library for solving packages and reading repositories"
+HOMEPAGE = "https://github.com/openSUSE/libsolv"
+BUGTRACKER = "https://github.com/openSUSE/libsolv/issues"
+SECTION = "devel"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
+
+DEPENDS = "expat zlib"
+
+SRC_URI = "git://github.com/openSUSE/libsolv.git \
+ "
+SRC_URI_append_libc-musl = " file://0001-Add-fallback-fopencookie-implementation.patch"
+
+SRCREV = "f654c8cfa52427ed42d7142e58452dae08c0c2d0"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "-DLIB=${baselib}"
+
+PACKAGES =+ "${PN}-tools ${PN}ext"
+
+FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibSolv.cmake"
+FILES_${PN}-tools = "${bindir}/*"
+FILES_${PN}ext = "${libdir}/${PN}ext.so.*"
+
+BBCLASSEXTEND =+ "native nativesdk"