aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libnsl/libnsl2_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-05-21 22:00:29 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-25 23:35:52 +0100
commitb73de31cbf58efb303006125f8cd22f130e21d8c (patch)
tree0e6acd7d92dfa51895046ad18ea8731aec03d79e /meta/recipes-extended/libnsl/libnsl2_git.bb
parent1aceb2dcf5bd671d90ec0517ed8f6fa817ea64c0 (diff)
downloadopenembedded-core-contrib-b73de31cbf58efb303006125f8cd22f130e21d8c.tar.gz
libnsl2: Add recipe
NIS functionality has been split out into independent library from glibc Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/libnsl/libnsl2_git.bb')
-rw-r--r--meta/recipes-extended/libnsl/libnsl2_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-extended/libnsl/libnsl2_git.bb b/meta/recipes-extended/libnsl/libnsl2_git.bb
new file mode 100644
index 0000000000..1698f69edb
--- /dev/null
+++ b/meta/recipes-extended/libnsl/libnsl2_git.bb
@@ -0,0 +1,35 @@
+# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Library containing NIS functions using TI-RPC (IPv6 enabled)"
+DESCRIPTION = "This library contains the public client interface for NIS(YP) and NIS+\
+ it was part of glibc and now is standalone packages. it also supports IPv6"
+HOMEPAGE = "https://github.com/thkukuk/libnsl"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+SECTION = "libs"
+DEPENDS = "libtirpc"
+DEPENDS_append_libc-musl = " bsd-headers"
+
+PV = "1.0.5+git${SRCPV}"
+
+SRCREV = "dfa2f313524aff9243c4d8ce1bace73786478356"
+
+SRC_URI = "git://github.com/thkukuk/libnsl \
+ file://0001-include-sys-cdefs.h-explicitly.patch \
+ file://0002-Define-glibc-specific-macros.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig gettext
+
+EXTRA_OECONF += "--libdir=${libdir}/nsl --includedir=${includedir}/nsl"
+
+do_install_append() {
+ install -d ${D}${libdir}
+ mv ${D}${libdir}/nsl/pkgconfig ${D}${libdir}
+}
+
+FILES_${PN} += "${libdir}/nsl/*.so.*"
+FILES_${PN}-dev += "${includedir}/nsl ${libdir}/nsl/*.so"