aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/images
diff options
context:
space:
mode:
authorStefan Stanacar <stefanx.stanacar@intel.com>2014-03-30 17:47:34 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-31 22:53:46 +0100
commit2764a40093644595cad9c095fb344912f9dc60fa (patch)
tree2b1ad6e82dca4281bacd2093b990b728716bbf19 /meta/recipes-extended/images
parenta4447e365026b6f1af74b48a4fbd5059c05afdbd (diff)
downloadopenembedded-core-contrib-2764a40093644595cad9c095fb344912f9dc60fa.tar.gz
recipes-extended: add master image for testing purposes
Add a custom recipe with custom initramfs and installers, that makes it easy to deploy a master image for testing purposes. We need a master image running on the target hardware, that should be a known good build, with a set of utilities installed so that we use it to deploy the images under test. This core-image-testmaster recipe isn't a requirement per se, any image can be used as long as the required conditions are met. The test code assumes: - that the device has a second rootfs labeled as testrootfs - it has a properly configured bootloader entry (called test) for the second kernel and rootfs - the master image has a /etc/masterimage file so it can differentiate between master and test images - the master image has tar, mount, bash (basically the normal linux utilities not the busybox ones) [YOCTO #5614] (From OE-Core rev: dea237ccd9407288cd3a73e1deca270619dd6d4a) Signed-off-by: Stefan Stanacar <stefanx.stanacar@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/images')
-rw-r--r--meta/recipes-extended/images/core-image-testmaster-initramfs.bb19
-rw-r--r--meta/recipes-extended/images/core-image-testmaster.bb18
2 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/images/core-image-testmaster-initramfs.bb b/meta/recipes-extended/images/core-image-testmaster-initramfs.bb
new file mode 100644
index 0000000000..563260d3b8
--- /dev/null
+++ b/meta/recipes-extended/images/core-image-testmaster-initramfs.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Small image capable of booting a device with custom install scripts, \
+adding a second rootfs, used for testing."
+
+# use -testfs live-install scripts
+PACKAGE_INSTALL = "initramfs-live-boot initramfs-live-install-testfs initramfs-live-install-efi-testfs busybox udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "core-image-testmaster-initramfs"
+IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+BAD_RECOMMENDATIONS += "busybox-syslog"
diff --git a/meta/recipes-extended/images/core-image-testmaster.bb b/meta/recipes-extended/images/core-image-testmaster.bb
new file mode 100644
index 0000000000..ac2fdbed32
--- /dev/null
+++ b/meta/recipes-extended/images/core-image-testmaster.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "A master image to be deployed on a target useful for testing other images"
+
+IMAGE_FEATURES += "ssh-server-openssh package-management"
+
+inherit core-image
+
+# the deploy code requires bash and
+# normal linux utilities not busybox ones
+IMAGE_INSTALL += "\
+ bash coreutils util-linux tar gzip kmod \
+ python-modules python-misc \
+ e2fsprogs e2fsprogs-mke2fs parted \
+ "
+# we need a particular initramfs for live images
+# that pulls custom install scripts which take
+# care of partitioning for us
+INITRD_IMAGE = "core-image-testmaster-initramfs"
+