summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/hdparm/hdparm_9.52.bb
diff options
context:
space:
mode:
authorFan Xin <fan.xin@jp.fujitsu.com>2017-06-07 14:55:26 +0900
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-09 17:12:06 +0100
commit3cd7aa486527d34bf6d20dd37046fe683230a4b6 (patch)
tree1e5f2cdc941fff41daa418b4c6217d899e0a1cc4 /meta/recipes-extended/hdparm/hdparm_9.52.bb
parentcf0679d7404a4b019282b947488fb078402e5931 (diff)
downloadopenembedded-core-contrib-3cd7aa486527d34bf6d20dd37046fe683230a4b6.tar.gz
hdparm: Upgrade to 9.52
1. Upgrade hdparm from 9.51 to 9.52 2. Update the checksum of LIC_FILES_CHKSUM The following content is appended to LICENSE.TXT, the licence is still BSD & GPLv2. The apt.c file is Copyright (c) 2009 Jan Friesse <jfriesse@gmail.com>. You may use/distribute apt.c freely, under the terms of either (your choice) the GNU General Public License version 2, or a BSD style license. Signed-off-by: Fan Xin <fan.xin@jp.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/hdparm/hdparm_9.52.bb')
-rw-r--r--meta/recipes-extended/hdparm/hdparm_9.52.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-extended/hdparm/hdparm_9.52.bb b/meta/recipes-extended/hdparm/hdparm_9.52.bb
new file mode 100644
index 0000000000..599cd303ab
--- /dev/null
+++ b/meta/recipes-extended/hdparm/hdparm_9.52.bb
@@ -0,0 +1,40 @@
+SUMMARY = "Utility for viewing/manipulating IDE disk drive/driver parameters"
+DESCRIPTION = "hdparm is a Linux shell utility for viewing \
+and manipulating various IDE drive and driver parameters."
+SECTION = "console/utils"
+
+LICENSE = "BSD & GPLv2"
+LICENSE_${PN} = "BSD"
+LICENSE_${PN}-dbg = "BSD"
+LICENSE_wiper = "GPLv2"
+
+LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=495d03e50dc6c89d6a30107ab0df5b03 \
+ file://debian/copyright;md5=a82d7ba3ade9e8ec902749db98c592f3 \
+ file://wiper/GPLv2.txt;md5=fcb02dc552a041dee27e4b85c7396067 \
+ file://wiper/wiper.sh;beginline=7;endline=31;md5=b7bc642addc152ea307505bf1a296f09"
+
+
+PACKAGES =+ "wiper"
+
+FILES_wiper = "${bindir}/wiper.sh"
+
+RDEPENDS_wiper = "bash gawk stat"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/${BP}.tar.gz"
+
+SRC_URI[md5sum] = "410539d0bf3cc247181594581edbfb53"
+SRC_URI[sha256sum] = "c3429cd423e271fa565bf584598fd751dd2e773bb7199a592b06b5a61cec4fb6"
+
+EXTRA_OEMAKE = 'STRIP="echo" LDFLAGS="${LDFLAGS}"'
+
+inherit update-alternatives
+
+ALTERNATIVE_${PN} = "hdparm"
+ALTERNATIVE_LINK_NAME[hdparm] = "${base_sbindir}/hdparm"
+ALTERNATIVE_PRIORITY = "100"
+
+do_install () {
+ install -d ${D}/${base_sbindir} ${D}/${mandir}/man8 ${D}/${bindir}
+ oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
+ cp ${S}/wiper/wiper.sh ${D}/${bindir}
+}