aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gzip/gzip-1.8/wrong-path-fix.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-12 10:21:02 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-14 13:01:58 +0100
commitc57ab66984bff1ea5596ffe592a0ca1e9ba82ab0 (patch)
tree19e459220842acf79d366803223c1780bbf1854f /meta/recipes-extended/gzip/gzip-1.8/wrong-path-fix.patch
parent1ac29df99c5533c7d6752b5756e9f0b43e2d9b64 (diff)
downloadopenembedded-core-contrib-c57ab66984bff1ea5596ffe592a0ca1e9ba82ab0.tar.gz
gzip: upgrade to 1.8
Drop the do_install musl append since the charset file is no longer installed. Refresh the patch. Also update the PREFERRED_VERSION. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/gzip/gzip-1.8/wrong-path-fix.patch')
-rw-r--r--meta/recipes-extended/gzip/gzip-1.8/wrong-path-fix.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-extended/gzip/gzip-1.8/wrong-path-fix.patch b/meta/recipes-extended/gzip/gzip-1.8/wrong-path-fix.patch
new file mode 100644
index 0000000000..4dc10002ed
--- /dev/null
+++ b/meta/recipes-extended/gzip/gzip-1.8/wrong-path-fix.patch
@@ -0,0 +1,29 @@
+fix MakeMaker issues with using wrong SHELL/GREP
+
+A set of substitution is being processed to all target scripts with sed by
+replacing some key words with the detected values at configure time, this
+is exactly not compliant with cross compling, and will cause missing path
+errors at run time like:
+"/usr/bin/zgrep: line 230: /usr/bin/grep: No such file or directory"
+
+Fixed by removing unneeded substitution and using real runtime paths
+instead.
+
+Signed-off-by: Ming Liu <ming.liu@windriver.com>
+
+Upstream-Status: Pending
+
+Index: gzip-1.8/Makefile.am
+===================================================================
+--- gzip-1.8.orig/Makefile.am
++++ gzip-1.8/Makefile.am
+@@ -81,8 +81,7 @@ gzip.doc.gz: gzip.doc $(bin_PROGRAMS)
+ SUFFIXES = .in
+ .in:
+ $(AM_V_GEN)sed \
+- -e 's|/bin/sh|$(SHELL)|g' \
+- -e 's|[@]GREP@|$(GREP)|g' \
++ -e 's|[@]GREP@|$(base_bindir)/grep|g' \
+ -e 's|[@]VERSION@|$(VERSION)|g' \
+ $(srcdir)/$@.in >$@-t \
+ && chmod a+x $@-t \