aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/groff
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-18 17:38:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-18 22:18:52 +0100
commitac7a0311825e20c544d17bfd8be63546ad36e665 (patch)
treefaf4f050bb8e629a5892f6eb7b0260583ca29451 /meta/recipes-extended/groff
parent63f545b850ea4118a7e9e412aa8a22206dc7da8c (diff)
downloadopenembedded-core-contrib-ac7a0311825e20c544d17bfd8be63546ad36e665.tar.gz
bitbake.conf: Define USRBINPATH globally instead of individually
Many recipes are now having to define PERLPATH and PYTHONPATH variables. Creating USRBINPATH in bitbake.conf means we can remove all these lines from the many recipes now needing this and simplify the code changes needed in each case, reducing the chance of errors being introduced. Also fixup glib python binary location issue and fix function indentation. (From OE-Core rev: cf63d9068c3a8c635dfc240d30dfff278be9b0e2) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/groff')
-rw-r--r--meta/recipes-extended/groff/groff_1.20.1.bb8
1 files changed, 2 insertions, 6 deletions
diff --git a/meta/recipes-extended/groff/groff_1.20.1.bb b/meta/recipes-extended/groff/groff_1.20.1.bb
index c5a475a348..c7da1b4178 100644
--- a/meta/recipes-extended/groff/groff_1.20.1.bb
+++ b/meta/recipes-extended/groff/groff_1.20.1.bb
@@ -18,10 +18,6 @@ DEPENDS_virtclass-native = ""
inherit autotools
-PERLPATH = "${bindir}/perl"
-PERLPATH_virtclass-native = "/usr/bin/env perl"
-PERLPATH_virtclass-nativesdk = "/usr/bin/env perl"
-
EXTRA_OECONF = "--without-x"
PARALLEL_MAKE = ""
@@ -43,7 +39,7 @@ do_install_append() {
# for target as /usr/bin/perl, so fix it to /usr/bin/perl.
for i in afmtodit mmroff; do
if [ -f ${D}${bindir}/$i ]; then
- sed -i -e '1s,#!.*perl,#! ${PERLPATH},' ${D}${bindir}/$i
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/$i
fi
done
}
@@ -53,7 +49,7 @@ do_install_append_virtclass-native() {
# for target as /usr/bin/perl, so fix it to /usr/bin/perl.
for i in afmtodit mmroff; do
if [ -f ${D}${bindir}/$i ]; then
- sed -i -e '1s,#!.*perl,#! ${PERLPATH},' ${D}${bindir}/$i
+ sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/$i
fi
done