summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-07-14 01:30:30 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-16 15:09:21 +0100
commit1195b41ff4a77fc922ec4ca55ed1acae91a856a4 (patch)
tree6bd79340f71d19b55db561eab8741da74122f34e /meta/recipes-extended/grep
parent7e51763e2291e9d12d3e81b859b2045530e0c009 (diff)
downloadopenembedded-core-contrib-1195b41ff4a77fc922ec4ca55ed1acae91a856a4.tar.gz
grep: use internal regex library with musl-libc
musl does not have the GNU regex API provided by glibc. http://wiki.musl-libc.org/wiki/Functional_differences_from_glibc#Regular_expressions (From OE-Core rev: 1bf295c85d72b7f6ac394e2c27e66ff507689314) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep')
-rw-r--r--meta/recipes-extended/grep/grep_2.5.1a.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-extended/grep/grep_2.5.1a.bb b/meta/recipes-extended/grep/grep_2.5.1a.bb
index 34d081be86..5a2da28327 100644
--- a/meta/recipes-extended/grep/grep_2.5.1a.bb
+++ b/meta/recipes-extended/grep/grep_2.5.1a.bb
@@ -23,8 +23,11 @@ SRC_URI[sha256sum] = "38c8a2bb9223d1fb1b10bdd607cf44830afc92fd451ac4cd07619bf92b
inherit autotools gettext texinfo
+EXTRA_OECONF_INCLUDED_REGEX = "--without-included-regex"
+EXTRA_OECONF_INCLUDED_REGEX_libc-musl = "--with-included-regex"
+
EXTRA_OECONF = "--disable-perl-regexp \
- --without-included-regex"
+ ${EXTRA_OECONF_INCLUDED_REGEX}"
CFLAGS += "-D PROTOTYPES"
do_configure_prepend () {